SafeSurf preventing installation of Adobe Reader9

This moring I loaded CFP 3.025 along with its toolbar and SafeSurf. This afternoon I am trying to download and install Adobe Reader 9 from Adobe’s site. SafeSurf exuberantly declares to have interrupted a buffer overflow attack. This occurs despite turning Firewall security level to “disable” along with turning Defense+ security level to “disable.” I can’t seem to find a similar control for SafeSurf. Of course there is always the option of uninstall, but that’s a rather clunky way to get apps up and running.

Try to exit Comodo SafeSurf and if that doesnt work end its process.

Advice taken, Note, stopping the process doesn’t do it, but disabling SafeSurf protection via the toolbar does (left click the SafeSurf icon.)

Exiting, Disabling and Un-installing SafeSurf all failed to enable the successful download of Acrobat Reader v.9 for me.

Does anyone know of another successful protocol to overcome this upgrade download problem associated with Acrobat Reader v.9???

Thank you for your input.


I am VERY new to my computer, Vista, and all relating to the both. I am now running Vista SP1 under a security product named Trend Micro using a “dial-up”, wireless card/modem and VZAcess. I’m running my security configuration reasonably conservative/tight. I too have tried a couple of Adobe Reader9 downloads which stopped at “90% complete”; actually 33.49 out of 33.5 MB downloaded. After uninstalling everything adobe I began the downloads again and fully from the adobe site: Adobe Flash Player version; Adobe Media Player which included Adobe AIR 1.1; and Adobe Shockwave Player (I did decline the pop-up offer of a free Norton PC Checkup). Then, I started the Reader9 download which wnet through a routine for the Adobe DLM install that quickly died due to a getPlus(R) error - Operating System error (a look at control panel shows that niether Adobhe DLM nor getPlus show up among the installed programs; from what I understand thus far, the getPlus(R) s/w is not an Adobe product.)

However, there is a line in light blued, which is a link, that says to click here if Reader9 doesn’t automatically download and to then click RUN in the next window - this is a download window for the AdobeReader90_en_US.exe. For myself, I was able to get this to execute correctly and get the file into an unspecified “temporary folder”. And, this is where any Adobe instruction ends. I was able to find an Adobe Technical Note, last updated 14Aug08, through a couple of different links. It is ID # kb405217. But, it doesn’t say much more than that they have a known problem and that the solution is to click on the link.

I happened to catch your post through the Yahoo search engine - be darned if I can remember what I typed for a search criteria. I’m now joined, and will stop back to see if anything else is posted along Reader9 installation and in general for the forum itself.

I found another Adobe Technical Note about installation problems with both Adobe Acrobat and Reader. I’m just starting to go through it but, thought I would post:
Tech Note ID # kb403923

For myself, I’m down to the point that I do not have the getPLUS(R) installer software installed on my machine. I did at one time but, uninstalled it along with all of the other Adobe software in an attempt to get things to load; if I remember, I was getting errors along the lines that items were already installed/downloaded on my computer. Ultimately, I did do a system restore which did bring up an Adobe Reader v8.xx back to my machine. (Vista has something that one of the Tech Helps in a more recent PC Magazine calls a “Virtual Store”. It is not something that one can bring up as a MS Help and Support item by name. So, the “Virtual store” must be an author’s or industry coined term for the system by which files are “deleted” in Vista. I have gotten a bit of a hint about it through multiple MS Help and Support topics…From what I can tell, it refers to the mechanisms that Vista uses to uninstall (O/S installation) software, how it deletes files from the registry as well at the file’s begin block, and then how the registry can repair itself during a restore; I would suspect that these mechanisms and conventions are also used by the various registry repair programs as well.)

I did have to manually re-install many of the Adobe extras such as Media Player, AIR1.1, and Shockwave. The installation routine pretty much took me and guided me to where I needed to go. For these routines, I was able to SAVE the files to my desk top and install by double clicking the icon on my desktop. On one of them, I forget which and by that time my notes weren’t as detailed as they should be, the installer said that the files already existed. But, I was able to follow what was on the screen well enough to locate a folder with that same s/w’s title which I did drag to the RecycleBin. From there, I was able to double click on the installation icon located on my desktop for a smooth installation.

At this point, I can click the Adobe provided link for a manual installation using RUN. But, the installation hangs when installing Adobe ADL because there is not a getPLUS(R) installer installed on the machine. I did find the site for getPLUS(R) but, wasn’t able to readily find a free download for this installer.

Have you tried downloading Adobe 9 from another location such as:

Does the download/installation work if you try exiting Comodo Safesurf from the Taskbar? (Bottom Right hand corner of your screen)


I tried exiting from the systray and no it didn’t help.How I did work around it was to download from the blue liine of text-a manual download- while leaving the box from safe surf untouched-except for moving it to the side of my screen.If I click on it Internet Explorer goes poof and any downloads you have going. Hittting the resume icon on your desktop also produces a box from safe surf.But the manual download went in fine.

Thanks for your workaround information.

You do know that you can actually excluded programs and processes from CSS. Perhaps actually excluding the program installer file would have worked.

Are you sure you downloaded the program from the correct site. I installed my Adobe Reader 9 without any issues directly from the Adobe Site itself.

Be wary of some other sites offering the download. Some are certainly less reputable than others.


I had the same problem with Adobe Reader 9 on two different computers, both with XP and Comodo SafeSurf. On the second computer I typed in the URL myself for Adobe and got the same response: the download works just fine but SafeSurf stops the install, saying it has stopped a buffer overflow attack. Here is the report I got from SafeSurf:
C:\Program Files\Internet Explorer\iexplore.exe
process id: 0x1630
thread id: 0x3E8
attack type: buffer overflow
address: 0x0C1B5F2
memory type heap

I will try disabling SafeSurf temporarily and see what happens.