Rules Meant To open any TCP port Leave all TCP ports closed [M967]

No need to worry about the OS. Thanks for the follow up information. If anyone has a Win 7 system could they try it on that please?

OK tested myself

To standard Proactive, added rules

  1. Advanced Settings->Security Settings->Firewall->Global Rules->Add new rule: Allow TCP or UDP In From MAC Any To MAC Any Where Source Port Is Any And Destination Port Is 49003
  2. Advanced Settings->Security Settings->Firewall->Application Rule ->Add new policy for Azarus (=vuze) with rule Allow TCP or UDP In From MAC Any To MAC Any Where Source Port Is Any And Destination Port Is 49003

On Win 7, I correctly get no alerts when running the Vuze main menu ~ Help ~ Nat test test tool and the test tool shows UDP and TCP ports open.

So this seems a win 8 bug…

Best wishes


I’ll pull out old one running XP and test with that. I don’t have one running Windows 7 at the moment. Thanks for your help troubleshooting.

Thanks that will help :slight_smile:

My test results:

  • Windows XP SP3 32bit: Ok
  • Windows Vista SP2 32bit: Ok
  • Windows Vista SP2 64bit: Ok
  • Windows 7 SP1 32bit: Ok
  • Windows 7 SP1 64bit: Ok
  • Windows 8.1 32bit: Failed
  • Windows 8.1 64bit: Failed

The devs have not been able to reproduce this issue. Please post which version of Vuze you are using and attach a video showing it reproducing on your system.

Let me know if you have any questions.


Thanks for the video. I have added the link to the video both in the tracker and in the first post.

Thank you.

I am using Vuze 32bit version. I noticed that Java is also 32bit, version 7 update 55. Windows 8 is 64bit. I still haven’t tried the other computer, been really busy. I’ll be able to run more troubleshooting next week.

Thank you. All of this information is now in the tracker for the devs.

Original SHA1 CIS v7.0.317799.4142 cmdhlp.sys and inspect.sys from c:\Windows\System32\drivers\

68cd68256b2c216c6ad1ded71d0b74712db163ad cmdhlp.sys
4e4821f62cd57f3bae02c1d7ace0e3cff520f8e7 inspect.sys

Deleted cmdhlp.sys and inspect.sys from c:\Windows\System32\drivers\

Copied CIS v6.3.294583.2937 cmdhlp.sys and inspect.sys to c:\Windows\System32\drivers\

Result: the rule is working now. At the moment: no crash and no blue/red/black screen.

Thank you for letting me know about this. I have added the information to the tracker that if you use the older versions of those two files the port rule works correctly.


Sorry, I haven’t been helping. I was really busy and also I updated to Windows 8.1 and it took a few days to get things running right again.

Is there anyway to get v6 of Comodo Firewall?

Nevermind I found the installer for v6.3.300670.2970.

Ok, well I uninstalled Comodo Firewall v7.0.317799.4142 and installed v6.3.300670.2970. Unfortunately I got the “The network firewall is not functioning properly” error. I decided not to bother troubleshooting that problem and instead just copied the two files np2359 mentioned. I uninstalled v6.3.300670.2970 and did a clean install of v7.0.317799.4142. I then replaced cmdhlp.sys and inspect.sys in the "C:\Windows\System32\drivers" folder. I created the ruleset as before and now Vuze runs fine. I ran Network Status plugin and got the following results:

Test starting Default public address is XXXX 0 NAT devices found No SOCKS proxy found No HTTP proxy found No explicit bind address set Testing HTTP outbound Test successful Testing TCP outbound Test successful Testing UDP outbound Test successful Testing TCP port 62405 inbound Test successful Testing UDP port 62405 inbound Sending outbound packet and waiting for reply probe (timeout=5000) Sending completion event Test successful 1 public/external addresses found XXXX Test complete
A special thanks to np2359 for figuring this out. I'll keep an eye on this thread in case the devs make any requests.

I found similar problem here:

There are solution too:

I fixed the issue by adding an allow rule for the "Windows Operating System" running process.

This solution work for me too.

I already have an application rule for “System” which seems to have been added automatically when my network was detected:

Allow System To Send Requests If The Target Is In [Home #1]
Allow, IP, Out, Any Address, Network Zone - Home #1, Any

Allow System To Receive Requests If The Sender Is In [Home #1]
Allow, IP, In, Network Zone - Home #1, Any Address, Any

What kind of rule do I need to create for “Windows Operating System”?

Although replacing the two files has fixed my TCP port problem, this new update is still causing problems. I’ve had the computer become unstable and freeze twice now. I’ll probably have to create a new thread/report if it happens again. It’s just seems to be one problem after another since the update. I ran Comodo for years without any such problems. It’s disappointing. :frowning:

Hi guys,

I am an engineer of COMODO, and I have tried t to reproduce the issue, but can’t succeed. Based on reply here, I have modified the codes, please download and test it, the test patch is for win8(including ofr x64 and x86).

Below is test steps:
1)Open folder %windir%\system32\drivers, rename cmdhlp.sys to;
2)Download and unzip the attached files, copy related cmdhlp.sys to folder %windir%\system32\drivers;
3)Reboot machine, test application which encounters issue.

If you have any question, please tell me.

Rick ■■■■

[attachment deleted by admin]

Thanks Rick, that’s very helpful.

I wonder if the reason you cannot replicate is because it is misdescribed in Jira? I attempted a clarification in Bugzilla @ 967 comment 6. Please note also this may be restricted to Win 8.1.

Best wishes


Hi Mike, in my lib, even without CIS, testing incoming TCP connections through port (any port) is failed. I don’t know why.

Best Regards,
Rick ■■■■