Rules for applications run from 8.3 format command line are ineffectual.

A. Application run via 8.3 format commandline rule malfunction.
Can you reproduce the problem & if so how reliably?:
Yes, every time.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Remove all CIS rules for target application (eg internet explorer) and apply so CIS does not have any rules for it operational.
2:Run target application in 8.3 format from command line (eg c:\PROGRA~1\INTERN~1\iexplore.exe )
3:When internet access requested, check remember and treat as allowed (so that it creates a rule).
4:Close target application and open again.
One or two sentences explaining what actually happened:
I formatted my computer and tried to get Battlefield 4 to work. The activation exe would never get internet access even when “remember” and “treat as allowed” were set.
One or two sentences explaining what you expected to happen:
The activation exe should have gotten internet access and activated the game.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
I think there is a clash with CIS to do with processing 8.3 file formats because when run normally, manually CIS works fine and allows the application internet access. But when an application executes another program in 8.3 format the rule gets applied in CIS but is never acted upon. A temporary one-shot workaround is to delete the rules and untick “Remember” and just press allow (not treat as) and that particular instance allows the application internet access.

Exact CIS version & configuration:
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Firewall only
Have you made any other changes to the default config? (egs here.):
Custom rule set ENABLED, Create rules for trusted applications ENABLED, Set alert frequency level VERY HIGH
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Microsoft Windows 7 Pro x64 UAC = Maximum, Administrator account, real PC not virtual.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Avira free antivirus (no firewall enabled)

All needed information to replicate problem and my assessment is included.

I cannot provide any attachments due to security policies relating to the potential privacy leakage of confidential/machine-level identification and configuration.

Should be fixed in version <>. If it’s not fixed, please PM me and I will move this one back for further processing.