Rule created, keeps asking never allowing. ActivationUI.exe (BF4 game)

I have even tried uninstalling, deleting app data for comodo, re-downloading just now, reinstalling and setting up and it does the same exact thing. I try and load up Battlefield 4 and the activation program runs, comodo asks me if I want to allow it, I tick remember and treat as allowed and then it asks again… then again… then again… then the activation program comes up saying it could not access the internet. Strangely the rule appears differently as you can see in this printscreen:

Location of the exe:

Almost like the old DOS 8/3 formatting. So I have a feeling a bug in CIS is preventing this from contacting the internet and is likely related to this 8/3 length formatting. The rule clearly is there… Yet it gets no internet and is really a problem because I cannot activate my game.

I would appreciate some help with this.

Have you tried manually adding the full path for the executable in the rule?

Yes. I removed the 8/3 format rule, applied, added the rule myself manually so it looks like a modern full length rule and still I have the same exact issue. I even tried just remembering and hitting allow to see if that would work. Nothing. Keeps asking and failing.

I just used Process Explorer to find some extra details. The exe in question is ran by the battlefield game’s exe and aside from parameters which contain credential/cookie information which I will not paste, the commandline that was used to execute this activation exe is as follows:


I notice a double backslash. I do not know if this is bugging out comodo but it might be something that can be tested.

I have just seen the same issue by trying to run internet explorer simply from 8.3 format:


When I run this from command prompt, after already having deleted all IE rules from comodo, IE comes up and asks for internet, I hit remember and treat as allowed. Then I see another one, then another, then another each time. Now, in the rules entry there is a normal looking entry (IE was able to get internet access but a second one must have tried to execute) and the 8.3 format rule would just keep asking and asking over and over even though I clearly already checked and saw the rule exists. So this is a bug in CIS.


A kind of workaround is to “allow” and not remember thus creating no attempt to save a record. This is a one-shot way to at least get the program to get internet that single time. But the rules system needs fixing for files run in 8.3 format.

This is a bug.

Did you change the registy setting to disable 8.3 filenanme support? If you did try enabling it back to see if that fixes the issue.

A hidden comodo registry setting? I have no idea about it.

No the windows registry setting for 8Dot3 file naming.

I never knew there was one. But if I blocked it I bet it would prevent the exe running. Which would be just as negative as it running without internet.

Hi there.

I have the same problem but with other programs. And strangely enough, they use 8.3 filename. I have noticed this problem only after the Comodo firewall update and I conclude that there is something about latest patches that caused this malfunction…
And I don’t remember that Comodo ever used 8.3 filename in rules of app paths before. But it is still malfunctioning if I manually add full path name.

I am also seeing the exact same issue (interestingly, also on ActivationUI.exe, but for a different game and path).

This issue started happening immediately after Comodo updated to No other changes were made at this time.

Comodo is simply ignoring the firewall rules applicable to this application (I have one with the full path name, one with the 8.3 name).

Can someone please pass this up the chain already? It is very annoying. Everything was fine until the update.

This is clearly a problem and it needs resolving.

Same here.
The rule works fine before the last udate.

The process path is: C:\aprogs\dev\bea\JROCKI~1\bin\java.exe

This block my job :frowning:

Please fix ASAP!