Rome Total War and D+

My son has been trying to play this game on his win7-64 system. It works fine except when D+ is active - in any mode, training, clean etc. There is one file D+ continues to block no matter what mode it is in. The only way of getting the game to work is by disabling D+. The file (the main game exe) is in the trusted file list, but according to the log it is being blocked.
Any thoughts?

try excluding it from the buffer overflow exclusions. its under defense + → defense + settiongs → execution control settings tab → exclusions at the bottom right.

Thanks for the suggestion, unfortunately that didn’t have any effect. However it did lead me to one that did. I had a look in the other D+ computer security settings and found an entry on in the list relating to the program. This setting must take priority over the trusted file list, as when I edited this entry to set it to pre-defined policy trusted, the program then ran