Roblox failing to connect [RESOLVED]

My son loves the Roblox site. The site installs files on the computer. I believe this to be a proprietary browser.

On the computer running Comodo, he keeps getting an error that he’s lost connection to the game. He is unable to play at all as the connection fails during the load.

I have searched this forum and found 2 related posts, however neither helped my situation. I have no notification from Comodo that it has blocked anything, I have listed the local programs as being Trusted, and running in Trusted Mode results in the same failure. Only if I disable Comodo Firewall can he can play.

What do I need to do to allow this site/program to run?

Thanks in advance!

Hello, Beuge. Welcome to the forum.
Have you tried placing Defense+ in Training mode?
Right click on the tray icin, go to Defense+, select Training mode.
Play the game, and after, place it back to the mode you were using.
That will create the rules you need to use the program.

Defense is and has been disabled. And with Firewall in Training and/or Safe modes, the game fails to run.

Are you behind a router?
Do the firewall logs show anything?

Not with regards to Roblox.

Though there is a lot of blocked TCP traffic for SVCHOST.EXE from source (my router) to my (my PC). Which I don’t understand. ???

Hello Beuge,

Did you try it with Firewall Security level set to Disabled ?
If the game functions correctly then you can be sure it’s the firewall that “causes” the problem.

Does that svchost traffic happen to be UDP traffic and is port 1900 involved ?

Hi Ronny,
Yes, as I mentioned in my initial post, if I disable Comodo, the game runs fine. But in Safe and also Training mode, the game chokes.

With regards to the svchost traffic, its TCP traffic with varying source ports: 1066, 1061, 1056 and more and destination port is always 2869.

Hello Beuge,

That also has to do with Plug-and-Play:

Allows this computer to receive unsolicited Plug and Play messages sent by network devices, such as routers with built-in firewalls. To do this, Windows Firewall opens TCP port 2869 and UDP port 1900. The default is Not Configured.

In this case the ip address with the port 2869 SHOULD BE your local pc’s ip address, otherwise it is likely internet probing traffic (normally this traffic should be between your router and your pc ip’s).

Also found this:

Does your application policy allow Roblox Allow, UDP, Outgoing, Src Any, Dst Any, Src Port Any, Dst Port Any ?

I think I hit on it: Under Firewall/Advanced/Attack Detection Settings/Miscellaneous, I unchecked 'Block Fragmented IP datagrams. Now Roblox plays without issue.

Can anyone tell me if there are concerns over leaving this option disabled…?

Thanks in advance. And thanks for all your help thus far.

Hello Beuge,

Glad it works now, seems their udp traffic fragments (could also be you are on a PPPoE connection) they also tend to fragment earlier because of the PPP overhead.

I would not worry to much about fragmented traffic, it can be used in specific cases to bypass a simple packet filter, If you are behind a hardware router i would leave it off, if your directly connected to the internet i would only disable it on gameplay, our try to find out if you can change you systems MTU size so it will fit the game and the “block fragmented packets” rules.

Awesome. Thanks for all the help, Ronny.
God Bless…

No problem :-))
and Thanks.