RFE: Do *NOT* use parameters in URL to identify a page

When i-Vault records the URL of what page from which it has recorded data entered into the fields on that page, it should NOT also include the parameters in the URL for that page. The problem is that the parameters could be different every time that page is visited, so i-Vault will record a NEW page on every visit although it is the SAME page.

Do not record:


But instead just record:


That is, record everything up but not including at or after the question mark used to delimit any parameters used within the URL. Then i-Vault can accurately determine that it is revisiting the same page regardless of what parameters are used or their values.

An an example of why including the parameters is a problem, go visit the SpamPal forums at:

Take a look at the “Login” link and notice that it goes to:


Each and every time you visit that page, the value of the sid object will be different. The only thing that i-Vault needs to know to recognize the login page is everything up to but not including the question mark and the parameters after it. Otherwise what happens is that i-Vault will record yet another entry for what it thinks is a different web page - and you will NEVER get it to pre-fill in the login credentials.

I haven’t a clue why the developers of i-Vault were so lazy as to not bother parsing the URL to truncate it on after after the question mark character. The parameters may be important in a link that navigates to a page but once AT that page then they are unneeded. Could be they are used to provide default values for controls on that page but then the purpose of i-Vault is to enter its own recorded values to insert into those controls (and overwrite any that may already be there).

Well, chalk that one up to a lazy user. I was digging around in the options and found “Do not strip arguments from URLs”. It is enabled by default after installation. I haven’t tested it yet but this looks like what I need so only the URL for the page is used to identify a page.

Applauded too soon. This option might do what I want but then i-Vault decided it shouldn’t save anything. It wouldn’t save the login credentials that it was supposed to. It created a new card but all the fields were blank. I tried using the Edit Card toolbar button while the card was selected but nothing happened. I had to right-click on the card itself (in the tree list or in the panel) and select Edit card. All the fields were blank. So i-Vault created a card when it detected the login page but didn’t even bother to save the URL for it. I then entered the URL, username, and password but they wouldn’t get saved. When I exit editing the card and go back in, there is no data anymore. While editing the card, you can push the icons next to each input field but you aren’t given a clue as to what is the difference with the button out or pushed in, and the docs suck.

I tried reenabling the “Do not strip arguments from URLs” option figuring there might be a code screwup that required this to be on to have i-Vault actually work. Nope, editing the card still did not get the data saved. Whether this option is enabled or not, i-Vault still keeps creating a new card everytime I visit the login page and enter my credentials.

Well, after trying to get i-Vault to remember my data when editing a card but it wouldn’t, I decided to exit and reload i-Vault. Now it would remember my card’s data - but it was still unusable since it would not use that data to pre-fill the login credential fields on the web page. From the other complaints here, like users losing their data altogether along with mine of not being to get it entered in the first place, the inability to recognize the same login page when revisited, and a big minus of not understanding how to present a drop-down selection of choices when multiple logins for different users will use the same login page (i.e., I’m the same user but I have several accounts at the same place) and of only using the last one saved for that site, it certainly looks like i-Vault is an alpha version of this product.

Plus I find it disgusting that I have to get stuck with their Launchpad rather than providing direct icons to their individual programs in the tray area and the lack of shortcuts directly to those programs in the Start menu. I very much DISLIKE the Launchpad which is just some childish attempt to advertise their other products and make their freeware very much like adware.

This sums up my experience too! I cannot use i-vault for over 50% of the sites I regularly visit and have now gone back to RoboForm.
Shame - it could have been a good add on with a bit of extra thought!


Reason: Out-Dated post.