Restart not working

This happened after last update:
“RESTART” function does not work (ie. when you have the option to logoff, shutdown or restart). I’ve tried different scenarios; manual “restart” fails, any type of updates or installs or programs that require/request a restart fail, etc.

When a restart is initiated (manual/automatic) the system shutsdown, screens blanks out & then … nothing. The system is still on but the restart never occurs. No hardrive activity, monitor goes into powersave mode. I wind up having to hold the power button to shut everything down.In order to boot I have to push the reset button on bottom of laptop. Other than this issue the system works fine. Boots up normally(after reset button pushed), powers down normally on manual shutdown. All applications work
normally … all good no error messages or BSD.

I’ve tried the following without success:

  • SFC /SCANNOW (doesn’t find anything)
  • CHKDSK (no errors)
  • virus scan picks up nothing.

A few years ago an update to firewall made my CHKDSK run over and over and not stop untill manual intervention.
Could this last update be the cause of this?

Sony GRX560
Win XP home SP-3
Comodo firewall only .587

When you say comodo firwall only, you mean you do not have defence+ installed? When you first installed CIS did you un-tick install Defence+? If you are absolutly sure that is the case, then there is a very little chance that comodo firewall is the issue as this souds like a defence+ issue. Also to just to be sure, could you please post a screen shot of the comodo main window the summary section.

Thanks for the reply,
The defence+ has always been activated and installed

I thought so, what you can do is set defence+ to training mode and then reboot your computer, then once you are back to the desktop and everything as loaded up fully in the backround, say 30 or more seconds after you login depending on how fast your computer is, then you put defence+ back the the previous level or whatever level you want to set it as. To set training mode for defence+, right-click on the CIS tray, highlight Defence+ security level, select training mode.

If training mode doesn’t fix it, there’s possibly a blocked Defense+ rule. You can also check the Defense+ log to see if anything was blocked.

Tried your suggestion and restart still shuts down and then power light stays on but no boot.
There are no entries in the defense+ log. (log is set for loging)

Test by “permanently” deactivating Defense+, but you’ll need to attempt to reboot twice (the first is required to apply the change, while the second is to see if the issue continues)

Edit: Before trying the above, have you tried the Diagnostics to see if it repairs anything? Also, what was your previous CIS version? If it’s many builds apart, you’d best do a clean reinstall.

Diagnostics found nothing wrong with install.
I have tried disabiling all instances of comodo running using “autoruns” program,manual shutdown and retart then tried restart button and still no restart, just goes off and power light stays on.
I do not know what the older version was but I check manually for updates every other day.
The first time this happened was after a restart after updating to .587 (was version before this)

I’m not familiar with autoruns. Is it capable of preventing drivers from loading? I think it’s better to test by disabling Defense+ permanently using CIS’ built-in function.

Edit: Looking back at your initial post reminds me of the issue where a USB device is connected to a PC that has USB support disabled in the BIOS. Something worth checking if it applies to you.

Autoruns ( Autoruns for Windows - Sysinternals | Microsoft Learn ) stops drivers from loading and I have used it for a long time.

Only have USB trackball connected and is enabled in BIOS

I was going to suggest you do a full uninstall of comodo and install the newest v3 and dont install the defense+ part, but version 4 has just been released maybe you can still do an uninstall and install v4 and see if it works. Also, how long do you wait after the screen turns off that you decide to hold down the power button to do a hard reset. The reason I say that is I have a laptop too and when I shutdown/restart after the screen goes blank, I can still hear the cpu fans running and my power light is still on. But it only lasts for 3-4 seconds and then I can hear it shutoff.

I have waited as long as a couple of minutes before hard shutdown.
When restart worked correctly it would shut down and within 2-3 seconds start right up.
I am running my computer lean and mean with only 20 or so processes to load at startup, the minimum amount of things that are needed to run windows.(all services not needed or used are disabled)
It boots up ready to go in 35 seconds and shuts down in 10 seconds.
As I posted about a problem in the past with a comodo firewall update causing CHKDSK to run over and over and not stop untill manual intervention,something in the registry was changed by the update and was not corrected until the next update.
Comodo was aware of the problem and corrected it.
I think this happened sometime in 2008.
I think that something of the same nature might have happened again.
Most of these updates are because of newer versions of windows.
I still am very happy with winXP and have no plans to upgrade.

Are you willing to try a clean install of 3.14?

If that is the case remember to export your active configuration to a folder that is not in the CIS installation folder (to make sure it doesn’t get erased in the uninstall). After uninstalling and reboot run this clean up tool before installing v3.14 again.

Can you first run CIS and reboot with the default installation and then import your old configuration and try rebooting again?

I have done this already.
What about the legacy entries in the registry?
Are they removed on the uninstall or left behind and overwritten on the new install?

The legacy entries do get replaced, but don’t really affect anything. If you’re curious, you can delete them by right-clicking on those “read-only” keys and enable Full Control permission.

You can also try version 4 if you’re up to it.

Thanks .
I manually had the restart button work 2 times.
I will now wait for update tuesday to see if it reboots and not freezes.