Restart not working after update to .587

This happened after last update:
“RESTART” function does not work (ie. when you have the option to logoff, shutdown or restart). I’ve tried different scenarios; manual “restart” fails, any type of updates or installs or programs that require/request a restart fail, etc.

When a restart is initiated (manual/automatic) the system shutsdown, screens blanks out & then … nothing. The system is still on but the restart never occurs. No hardrive activity, monitor goes into powersave mode. I wind up having to hold the power button to shut everything down.In order to boot I have to push the reset button on bottom of laptop. Other than this issue the system works fine. Boots up normally(after reset button pushed), powers down normally on manual shutdown. All applications work
normally … all good no error messages or BSD.

I’ve tried the following without success:

  • SFC /SCANNOW (doesn’t find anything)
  • CHKDSK (no errors)
  • virus scan picks up nothing.

A few years ago an update to firewall made my CHKDSK run over and over and not stop untill manual intervention.
Could this last update be the cause of this?

Sony GRX560
Win XP home SP-3
Comodo firewall only .587

Can you show us a screenshot of the Defense + logs? They can be found under Defense + → Common Tasks → View Defense + Alerts.

Please check under Defense + → Advanced → Defense + Settings and let us know if you have “Block all unknown requests if the application is closed” enabled or disabled (default).

Defense+ log is empty.
Block all unknown requests if the application is closed is disabled

[attachment deleted by admin]

Try disabling Defense +. Go to Defense + → Advanced → Defense + Settings → now enable “Deactivate the Defense + permanently (Requires a system restart)” → restart as requested and try again. Does the same thing happen?

duplicate 88)

Yes the same thing happens.
As I posted about a problem in the past with a comodo firewall update causing CHKDSK to run over and over and not stop untill manual intervention,something in the registry was changed by the update and was not corrected until the next update.
Comodo was aware of the problem and corrected it.
I think this happened sometime in 2008.
I think that something of the same nature might have happened again.
Most of these updates are because of newer versions of windows.
I still am very happy with winXP and have no plans to upgrade.

I will lock this topic because it is a duplicate post.The other topic is longer and is “more mature”.

I will reply in the other topic.