'Resolving host...' issue

‘Resolving host…’ seems to be occurring more and more frequently and almost all the time, now. I updated Comodo Dragon to version 43 recently, but I think ‘Resolving host…’ was happening before that, probably. I have powered the router off and on again twice in the past couple of days; I run CCleaner daily to clear caches; I delete Comodo Dragon’s history daily, at least, too. I read there are various possible solutions. I wondered what is users’ advice?

Hi Bob Hawkins,
Try disabling ‘Malware domain filtering (Comodo Secure DNS)’, found under privacy in the advanced settings and see if that helps.


I thank you for your advice. I had entered Google’s DNS server in my Network and Sharing Center because of what I read elsewhere. Things have definitely improved whether by chance or this action. I shall copy your suggestion for future reference, however, in case the deterioration reoccurs.

I think you have come up trumps again!
Inserting Google DNS server details was not the answer, it seems: it would be OK for a while but I have been forced since to switch the router off and on to overcome the ‘Resolving host…’ issue, which reoccurred. I carried out your suggestion to disable ‘Malware domain filtering (Comodo Secure DNS)’. So far, so good.
More recent posts suggest my difficulty is related. You alerted me to Comodo Dragon update to version 43 on 18th July. I wonder if this malfunction is related to that update?