[RESOLVED] Need support: Friend unable to use many features

Hello. I firstly apologize if this is in the wrong forum, secondly I thank you for reading this.

My friend recently obtained a computer from me, basically a hand down. On the computer I installed the following software for security

•Comodo Internet security (Free)
•Avast Anti-virus

For support I installed team viewer as I’m not that bad with computers and can fix most problems. The computer is currently running Microsoft windows XP service pack 2 home edition, version 2002, I am unable to update the system to service pack 3 and unable to update some critical vulnerabilities. This is not the only problem with the system.

•He currently cant sign onto any secure website (hotmail, gmail, paypal)
•He can’t use the Comodo taskbar icon menu in the bottom right corner (when right clicked and an option selected. The menu will freeze until its right clicked again)
•As said he can’t update the system and many programs like Comodo

I’ve tried many things to fix this problem. I’ve ran virus scans simultaneously from different vendors and all have come back clean.
I’ve registered the key .dlls that are needed
I’ve configured the Comodo firewall and even disabled it to see if that was the problem
I’ve been observing incoming and outgoing connections to see if the system had been hijacked by a Trojan or a Botnet. Everything is legit.

Ultimately I know I can fix the problem by reinstalling windows but I’m trying to avoid that as it is time consuming. Can anyone offer me some advice please :a0
I thank you for your time once again.

guess we need to sort out one by one. First lets check with sp3.
Disable your security softwares and try to install sp3 from safe mode. If it doesnt work, post the error message you get. If it works, then enable your security softwares. Its advisible to unstall the security software to install sp3 and reinstall once its done

Ok thankyou. I will post back asap.

Hello. I’m sure I posted back but it appears I haven’t.

I reinstalled windows on my friends computer but he still cannot do the features listed above. Please provide me with further assistance.

Thank you for your time

Hi Benjamin,
As you have mentioned that you reinstalled the windows os, i would ■■■■ to have some more information. Did you tried to install sp3 as once you have done the reinstallation or you installed all the other softwares and then tried to install sp3 ? Whats The error message you get while installing Sp3 ?


No, unfortunately I installed no software and tried to update to service pack 3. This is the error number I got on the windows update internet page

Error number: 0x80072EFE

But I am now able to right click the Comodo taskbar in the right hand corner :smiley: so that’s kinda nice and a start I suppose ;).

Hi Benjamn,
This Error Code Orrurs Becuase Of Many Reasons. However To Narrowdown The cause, I Would Request You To Upload The Following Files Which You Can Find Under Your Windows Folder



Sorry for the delay, lots of tests at college which has kept me occupied. I will upload the logs in a few days when I next see him.

Thank you.

Fine… :slight_smile:

I’d do a disk scan, a dllcache clear (you can use sfc command in cmd), then an “sfc /scannow” (system cd needed). Can your friend log in to https sites with other browsers? If yes, can you check IE settings, is it allowed to save secure pages onto the disk (this option is at the Special tab)?
0x80072EFE should be a connection problem, have you got any damaged sys files, yellow devices at device manager (start>run>devmgmt.msc)? If this is caused by the damaged WMI, you shall use a wmi repository fix (google it).

Hello Arkangyal and napsterz

There are two yellow devices in my friends hardware tab. One called “network controller” and the other called “PCI simple communications controller”

My friend cannot log into Http sites from other browsers. He is currently using Firefox latest build and he is for some reason, able to use “ILOVEIM” to log into his msn and use Bebo, I am not sure why.
I have also repaired a possible damaged WMI by researching the fix on google. Thank you for your time, I hope this information was of some use to you.

Due to the restrictions of comodo forum attachments, I will have to provide you with an external link momentarily. I was unable to find Svcpack.log within the windows folder but I was able to find WindowsUpdate.log

I have also obtained a downloaded update of service pack 3. The system will of been updated once you read this. I will provided the link to to the log in a second.

Thanks for your time :wink: You are both a great help.

Files Upload Sucsesfuly

Thanks, your files will be deleted after 7 Days
This is your files link :

I Went Through The Log,

009-06-18 19:26:59:593 1060 e74 PT WARNING: Cached cookie has expired or new PID is available
2009-06-18 19:28:00:953 1060 e74 Misc WARNING: Send failed with hr = 80072ee2.
2009-06-18 19:28:00:953 1060 e74 Misc WARNING: SendRequest failed with hr = 80072ee2. Proxy List used: <(null)> Bypass List used : <(null)> Auth Schemes used : <>
2009-06-18 19:28:00:953 1060 e74 PT + Last proxy send request failed with hr = 0x80072EE2, HTTP status code = 0
2009-06-18 19:28:00:953 1060 e74 PT + Caller provided credentials = No
2009-06-18 19:28:00:953 1060 e74 PT + Impersonate flags = 0
2009-06-18 19:28:00:953 1060 e74 PT + Possible authorization schemes used =
2009-06-18 19:28:00:953 1060 e74 PT WARNING: GetCookie failure, error = 0x80072EE2, soap client error = 5, soap error code = 0, HTTP status code = 200
2009-06-18 19:28:00:953 1060 e74 PT WARNING: PTError: 0x80072ee2
2009-06-18 19:28:00:953 1060 e74 PT WARNING: GetCookie_WithRecovery failed : 0x80072ee2
2009-06-18 19:28:00:953 1060 e74 PT WARNING: RefreshCookie failed: 0x80072ee2
2009-06-18 19:28:00:953 1060 e74 PT WARNING: RefreshPTState failed: 0x80072ee2
2009-06-18 19:28:00:953 1060 e74 PT WARNING: Sync of Updates: 0x80072ee2
2009-06-18 19:28:00:953 1060 e74 PT WARNING: SyncServerUpdatesInternal failed: 0x80072ee2
2009-06-18 19:28:00:953 1060 e74 Agent * WARNING: Failed to synchronize, error = 0x80072EE2
2009-06-18 19:28:00:953 1060 e74 Agent * WARNING: Exit code = 0x80072EE2
2009-06-18 19:28:00:953 1060 e74 Agent *********
2009-06-18 19:28:00:953 1060 e74 Agent ** END ** Agent: Finding updates [CallerId = AutomaticUpdates]
2009-06-18 19:28:00:953 1060 e74 Agent *************
2009-06-18 19:28:00:953 1060 e74 Agent WARNING: WU client failed Searching for update with error 0x80072ee2

Actually This Is A Connectivity Isssue As Mentioned By Arkangyal. On Most Of The Cases, It Should Be A Port Block On The Router. Since You Have Mentioned That He Is Not Able To Browse The HTTP Sites, Verify that you can connect to SSL enabled Web sites. The computer uses a secure HTTP port to connect to Windows Update and Microsoft Update.

I Would Request You Do The Below Mentioned Steps Which Can Be Found In KB 818018 Windows Update issues troubleshooting - Windows Client | Microsoft Learn To Test Whether Port 443 Is Open

  1. Click Start, click Run, type https://www.microsoft.com:443 , and then click OK.

  2. If you cannot connect to https.microsoft.com, or you receive an error message, the
    port may be blocked.

Workaround: Bypassing The Router And Connecting The Computer Directly To The Modem

Your friend can try out this forum access using https, instead simple http (just type in a +s after the http in the address bar).
Please, right-click on the marked entries, click Properties and check what their problem is - i’d bet on missing file or not installed correctly message, if so:
Step 1: I would complety remove the network card devices (they are below the +Network devices tree) - at first, please download the driver softwares for the user’s cards - (select the cards from the device handler you have been, right-click and remove).
Step 2: reboot.
Step 3: disable on-access softwares (try to do this before specifing the location of the driver files). For an advance security step, unplug network cable or the modem during the below steps.
Step 5: reinstall hardwares - if Windows could (lets hope :)) recognise the new devices and you got .inf file in the driver packet, specify the correct path to that file.
Step 6: reboot, check device manager again.
Step 7: switch on on-access softwares, network devices (modem, etc.).

At first, you shall only remove the PCI harware entries (e.g. do NOT remove WAN miniports and entries which got no product names /such as Realtek, Belkin, Intel, etc. are ok/).
Some of the cards - especially wireless kinds - got driver files you need to install BEFORE you insert the card (please, read the user manual of the card if that is the case).

Thanks! My friend is now able to log into sites ;D Infact I’m now logged onto his computer :slight_smile:

You have both been a great help trouble shooting this problem :slight_smile: its 100% fixed O0 Cheers!

Hello Benjamin,

We are glad you could resolve the problem :)! I’ve closed this thread, let a moderator know if you want to re-open it.