Repeated s/bing of trusted batch file causes failure to run Apache server [NBZ]


Trusted File Not Being Trusted

The bug/issue

  1. What you did:
    Launched EasyPHP 5.2.10

  2. What actually happened or you actually saw:
    “Application Isolated Alert”
    For “chkap.bat” resulting in the Apache Server being blocked from running.

  3. What you expected to happen or see:
    Expected EasyPHP to run as planned. It ran fine in the previous CIS version.

  4. How you tried to fix it & what happened:
    I made “chkap.bat” a trusted file, which didn’t resolve the issue. After making it “trusted”, & re-launching EasyPHP, the same CIS “alert” as before was launched.
    I even tried “clicking” the “don’t isolate again” link in the CIS Alert, to no avail.

  5. Details (exact version) of any software involved with download link:
    EasyPHP 5.2.10
    EasyPHP Devserver & Webserver - Browse Files at

  6. Any other information you think may help us:

Files appended

Your set-up

  1. CIS version, AV database version & configuration used:
    CIS 5, latest AV database, AV config is “Stateful”

  2. Whether you imported a configuration, if so from what version:
    Configuration is the same I used from the previous CIS version.

  3. Defense+ and Sandbox OR Firewall security level:
    Defense + level is “Safe Mode”, Firewall level is “Custom Policy” (which asks what to do for ALL programs that I have not set a policy for).

  4. OS version, service pack, no of bits, UAC setting, & account type:
    Vista Home Premium SP2 32-Bit…UAC is off, Administrator Account type

  5. Other security and utility software running:

  6. Virtual machine used (Please do NOT use Virtual box):

Thanks for a very useful issue report.

To work out what is happening we would be very grateful if you can append:

  • A screenshot of your D+ event logs after snadboxing has occurred, and preferrably covering a prior boot
  • A screen shot of your complete active process list taken while the alert is showing
  • A copy of chkapp.bat

Many thanks and best wishes


Nice to see you again Mouse (Mike). We whooped that InputPersonalization.exe & problem I had in the last version together. :smiley: I know it is off topic, but I just wanted to say that the help that you & the other Mods give Comodo users is a real testament to the quality of Comodo products, especially since they are free. I tip my hat to you sir, your peers.

Before I add what you requested, there is one thing I am going to try first. That version of EasyPHP I was using is an older version, so I am going to download & try the latest version of EasyPHP first. Even if the problem is still present, I want to use the new version of EasyPHP anyway. So if I still have the same problem, I will post a full “bug report” here in this thread again, including what you have asked of me to add in addition to what I posted.

Thanks Mike.

Thanks for changing my thread title to a more appropriately informative title. I wasn’t really sure the best way to title it to be as accurate of a reflection of the problem at hand.

Yes I do remember, many thanks for your help on that occasion and many thanks to for the positive feedback. We get a lot of flack sometimes so it is very welcome. :slight_smile:

Regarding this issue happy to wait while you experiment - suspect the problem is more general than just this executable though. The script security support is still bedding in - and batch files are treated as scripts (roughly speaking).

Best wishes


Ok Mike, here goes.

D + Event Log

Active Process List ( I had to break it down into two screenshots to capture it all )

Strange thing about this chkap.bat file. It isn’t located in the location that it shows in the D+ Event Log. In fact I can’t find it at all. I am not sure what to make of this honestly.

And you were right, the latest EasyPHP version didn’t fix things. :smiley: I figured as much, but was hoping for the best.

Hmm in this case as is frequently true with batch files the APL does not help.

I think we have to see if we can find chkapp.bat first, if you wouldn’t mind searching for it using Windows explorer search and searching for all files inc hidden and system files.

Next thing would be to work out what file is invoking chkapp.bat, if you don’t know. More difficult this - start with Apache and EasyPHPL directories and try an Windows explorer string search.

Finally if you don’t mind using Microsoft process explorer to see the invocation sequence for Apache, and double click on the apache process to see if it has a Comodo job tab. Take a screenshot of the invocation and the job tab if you find one.

This tape will self destruct in 10 minutes!!!

I you need any help just ask.

Best wishes


PM sent

Another PM reminder sent. Leaving at WBZ meanwhile.