Reordering entries in D+ "Computer Security Policy" sometimes removes them [282]

The bug/issue

  1. What you did: Reordered (drag&drop) entries in “Computer Security Policy”.
  2. What actually happened or you actually saw: The entry at the bottom of moved entry is deleted (forever from config when clicked “ok”).
  3. What you expected to happen or see: Nothing removed, obviously.
  4. How you tried to fix it & what happened: Clicked cancel when observed missing entry or slider expanded, and tried again or forget.
  5. Details (exact version) of any software involved with download link:
  6. Any other information you think may help us: It seems that this bug only occurs when moving entries surrounded by two file group entries (in space between my custom group I made (for Opera Widgets) and “Windows System Applications” or “Windows Updater Applications”).

Files appended

  1. Screenshots illustrating the bug:
  2. Screenshots of related event logs or the active processes list:
  3. A CIS config report or file.
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.162636.1135 / 6262.
  2. Whether you imported a configuration, if so from what version: From latest 4.x version, config is customized “proactive security”.
  3. Defense+ and Sandbox OR Firewall security level: D+:paranoid/SB:enabled/FW:custom policy.
  4. OS version, service pack, no of bits, UAC setting, & account type: XP SP2.
  5. Other security and utility software running: None.
  6. Virtual machine used (Please do NOT use Virtual box): None.

This did not happened in 4.x so it is for sure some introduced bug in 5.0.