Removal failure:need forced removal?

I recently installed a Video downloader.

I was not happy with its behaviour, so I tried to uninstall it using CPM The option was for a Standard Uninstall. Immediately the uninstall started, a message popped up saying that in order to complete the installation (it may have said removal) the PC needed to be restarted. Although I felt it was all a bit fast, I said yes. The result was that the application remained in place after restarting. This happened 3 times.

In each case, I had to re-start CPM in order to have another go, as it seemed to freeze, even after I had hit the Cancel button to end the uninstall.

Comodo IS also sandboxed a process connected with the uninstall. Looking at Defence listings, it appear the boxed app was related to the uninstaller of the app, and not CPM.

After the first failure, I had to use another app that had a Forced Removal option, which just removes all references, pretty much regardless of what the installed programme tries to do. This option does not seem to be available in CPM.

I have tried installing again and the uninstall seemed to work using CPM, without that restart message.

The difference is that I now have Web access, which I did not have when the uninstall failed. I had no access because, in reaction to the behaviour of the app, I stopped all services using CIS. So it would appear that if the app cannot get to its site, it causes this uninstall failure.

I just thought that this may present a loophole, as it did allow a programme to refuse to be uninstalled.


Mod Edit: Corrected spelling error in title, Captainsticks.

You may want to report the title of the programme; otherwise the results are vague.

My guess is you needed to remove the sandboxed uninstaller from the sandbox so it could do what it needed to do. Comodo Programs Manager has a Forced Uninstall option, though. It’s in the settings.

Some sites do not like you “naming names” or discussing specific software.


The programme in question is Speedbit’s Video Downloader.

The item is only sandboxed if the Web is not available. I am not sure I know remove something from the sandbox.

I tried it with Forced Uninstall selected. Again this was with the web off in CIS. I had the same message about needing to reboot. Then I waited and up popped a message saying that the uninstall had been successful. However then the programme tried to open Internet Explorer. That failed, with IE “not responding”. When I went back to CPM, there was an error message (no ID on what programme had it) Runtime error 217 at 04F7378B.

Again CPM had frozen and had to be restarted to work.

However this time, the programme HAD been deleted. So workable but messy. The problem seems to me to be that CPM still allows the uninstaller of the programme to try to do the job. The other uninstaller I use will simply jump straight to removing all files and registry references, if in forced removal mode. Hence less control by the uninstalled programme and less mess.