Remember my answer

After running various leak tests it was discovered that “safe” programs are not necessarily safe. I wish to have the Comodo firewall ask me each time to allow a program permission to access the internet which will allow me to stop the leaks that occur in these “safe” programs. It will pass all leak tests when this is invoked. However, IE, OE, & Eudora always have the “Remember my answer for this application” checked which means I have to uncheck each popup each time for each application before I “Allow” access which is rather annoying. Clicking to Allow is hardly a problem, but having to uncheck the boxes to “Remember” each time is.

Under Security/Advanced, I have “Automatically allow safe applications” unchecked and also “Basic popup logic” is unchecked but the Remember box is checked each time I start these applications.

Are there any suggestions as to how to get this firewall to accept the fact that I don’t want these applictions to “Remember my answer” and stop inserting the check in the box automatically?

If you have “basic Popup Logic” unchecked it will pop up for every port, every activity, everything and you’ll get millions of popups. Leave Basic Popup Logic on as it’ll save you hours if not days of hassle. Unchecking “Automatically allow safe applications” is all you need to do if you want to be asked about every application.


Thank you. I did have it set to popup everything which would not be a problem if I did not have to uncheck the “Remember” box every time. Generally it was 4 popups per application. I tried uninstalling, reboot, wiping the registry for Comodo, reboot and reinstall, but it still does the same thing. When I reinstalled I did not do the “Automatic config” but did the config manually, with no difference. I have now checked the “Basic popup logic” to cut down on the ones I have to uncheck. It is just IE, OE and Eudora. For some reason Outlook does not do this. I sent an e-mail to tech support and they answered once asking for additional info which I provided about a week a go and, so far, no additional comments from them. I sent a followup and that has so far not produced any response. I am assuming they don’t have an answer for this one, so I was hoping someone else would have some thoughts on something to try to stop Comodo from automatically entering the check in the box to “Remember” for these applications. Except for this little annoyance, this is the best firewall I have used.

What is strange is I have seen some posts where just the opposite is happening. They will check to “Remember” but it does not.