Reformatted but still need nonexistant password

Windows Vista Ultimate 64 bit
300 GB HD x2 (RAID 0) = 600GB
HD Radeon 4870x2
Used latest non beta version of CDE on Apr 27th 2009

I downloaded and tried CDE out of curiousity and installed it.
I encrypted my main drive and set it to ask for a password on boot.
It completed successfully. I left my computer on all night to let it do this.
After a while I shut down my pc, then came back later to turn it on.
It loaded up to the point where it asks for the password prior to windows loading, as soon as it starts to access the hard drives I believe. I entered my password. Nothing happened. I’m aware that there is no “echo” and in other word’s I can’t see what I’m typing, but even after I enter it and press enter nothing happens. No error, no hard drive working light, no nothing. I have read that other people encountered an error if their password was wrong. I am getting nothing like that. The " | " mark just keeps flashing, waiting for some sort of input. I restart my computer several times trying the password again and again, even trying other passwords though I am very sure of which one it is since I use it often and was only testing CDE anyways.
I attempt a windows repair, but the disc cannot see that there is an OS on the discs, even after loading the usual driver for my RAID 0 setup. I load Ubuntu off a disc to check my system. It recognizes that all the harddrives are there, but I can see no way of decrypting anything.
So, disgruntled at the loss of nearly 500GB of information, pictures, and games I reinstall windows using a backup disc I made right after I had done a fresh install and had only added the basic drivers.
Windows installs successfully and I begin to reinstall my programs and games. I leave it running for a while, downloading my drivers and games, and then come across a blue screen. My computer restarts. It is asking for a password again, and still will not accept anything that I type. I know my keyboard is working because ctrl alt del still resets the system.
This time I try several methods of reformatting the drives, both in ubuntu and using the vista install disc. I can’t seem to find anyway of doing anything other than a quick format. I reinstall windows again after this. Before installing anything else I reset the system. It works. I install a few drivers and reset again. It works. Still suspicious I shut down my system entirely and wait a minute or two, then start it up again. Now it is asking for the password again. What gives? Where is this password BS even stored at now if my harddrives have been formatted? Is there some part on the disc I haven’t successfully wiped? I tried undoing the raid 0 and formatting them individually using ubuntu, switched back and forth from a list of random formats. After this I set up the raid again and rebooted. This time it simply asks for me to insert a boot drive instead of a password. I reinstall windows AGAIN and then reset once. As before it works. Then I tried shutting down and then starting up. AGAIN it asks for a password to access my discs. Where is this stored and how do I get rid of it? How can it be this complicated? I’ve wasted hours upon hours and lost a lot of data. I don’t want any sort of disc encryption anymore, how do I get rid of this for good?
I’ve tried some of the options in other topics about resetting the boot sector, but my vista disc(s) don’t seem to want to follow along with the instructions. Do I need an XP disc? Do I need to do a full reformat and not a quick one, and if so how can I do that without a windows XP disc?
Please help, this is really annoying and I’d just like to get my computer running normally again.

My guess is that if you had a copy of the MBR, master boot record, AND you had not overwritten data, AND you remembered the password, then you might have been able to boot from CDrom or USB and repair things. All this assuming there is not a hardware problem. (even then you might be able to fix that with disk repair software.) Doesn’t sound like that is possible now.

It isn’t clear what you meant by “successfully” reinstalling Windows. Did you ever boot to Windows following your reinstall attempt? If NOT, then it seems likely you have written the system to disk but NOT changed the boot sector. Fulll disk encryption requires the encryption software to alter your boot sector, so the computer can load a minimal temporary “operating system” which can “decrypt” the required system software prior to boot, load the main OS files into memory, and boot. Somebody here will probably sugges the best way to edit and overwrite the encryption software out of that boot sector.

Ensure you have “USB Function For DOS” set to ENABLE in your bios. If you used the USB thumb drive as a security key, it will not be seen until that option is turned on in the bios.

I found this out a little too late because I had the same problem. Put in my password and says OS not found. I wiped my drive and reloaded XP, installed CDE and put in a simple password like abcd and got the same, OS not found. The light on my USB key was not lit so I looked in the bios and enabled that option and the light on my USB key lit up and I was able to log in.

USB is enabled, though I never set it to require a USB key.
I never forgot my password. When I went to enter it in nothing happened. I am aware that it doesn’t show what you are typing, but no matter what I type nothing happens. No “incorrect password” error, no “OS not found” or anything, just the blinking " | " symbol. The keyboard is working because CTRL ALT DEL still restarts the system.
I had written that I was able to load windows successfully and start installing software, and also that I was able to reset and still have it load. It’s only after booting up from being completely shut down that it asks for the password again. Again, I can get windows installed and do whatever I want except for shutting down completely.
I don’t currently have a windows XP disc, though I could probably borrow one from someone if needed.
Formatting a disc doesn’t erase the boot sector I suppose, or is that because I was only able to do a quick format?
Also, is it possible that there are certain symbols a password cannot contain? My password had the “@” symbol in it. Just curious.
I don’t suppose comodo has any recovery software for this in case of a similar error? Not oblivious enough to think there’d be a way to recover without the password and USB stick if needed, but just in the case that the interface for entering the password isn’t working it’d be nice to be able to boot from some sort of recovery disc that loads USB drivers and allows me to input my password there with the option to unencrypt.
Is it possible that it doesn’t like RAID 0?

I will try to obtain an XP disc later tonight and I’ll write if it was successful or not.

Using the command prompt on the vista disc in recovery mode “format c” worked to get rid of the encryption. Took a while and deleted everything, but at least now I can start over.

If “Enter the password:” prompt message appears at boot time this means that CDE’s bootloader is installed. The cde’s bootloader is installed just because CDE installs a new bootloader, before starting any encryption process. It semms to be a bootloader problem. You should fix the MBR before trying to restore your partition.

Please follow this link and fix your MBR, and try to boot again.