Redirect loop message


Is there any way to bypass redirect loop message.
When you search for pictures on google and clicking on some of the results instead to open it in same/new tab it shows “This webpage has a redirect loop probably caused by secure connections enforcement”


Try disabling Comodo Secure DNS in Dragon’s settings and any system DNS you may have enabled.

Providing some example links would also be appreciated.

Thank you.

I don’t use Comodo DNS servers

example i just made.

clicked on first search result and


Do you have HTTPS pinning enabled for Google (the lock icon in the address bar)?
You have to disable the option for the page to load because some web pages do not support HTTPS and Dragon will attempt to force them to load this way.


that is the first thing i looked

HTTPS pinning is performed independently for each website. You have to navigate to “” (or whatever your regional Google URL is) and disable HTTPS pinning for that address.

The last image you posted does not show whether the Google search page is loaded or not.

Thank you.

HTTPS pinning was disabled by my part on google domain, but it didn’t work
I finally managed to get it work by clicking 4-5 times on don’t force https

when the lock is gray it’s disabled, and green is on, but it seams it was some kind of lock that interfere that command
ps: When you open it turns https forced mode on !