Recover process failed with code 4

Windows Server 2003 Standard Edition 5.2 (build: 3790) Service Pack 1

CPU: Intel(R) Xeon™ CPU 2.80GHzn at 2790 MHz (x 2)
Current CPU Utilization: 4%
Physical memory: 15% (Total: 4,031.39 MB, Free: 3,392.91 MB)
Commit memory: 4% (Total: 7,956.46 MB, Free: 7,566.82 MB)
System Bios: DELL - 1, 04/05/04
Screen: 1024 x 768 16 bits Video Bios: 02/07/29

Publisher: C-O-M-O-D-O
Version: 2.1.118414.11

Receiving the following error in the log when trying to restore from backup:

25.11.2009 12:22:36 Opening Backup…
25.11.2009 12:22:36 Initializing Restore Information…
25.11.2009 12:22:41 Starting Restore Process…
25.11.2009 12:22:41 Processing S:\LFDATA\DEFVOL
25.11.2009 12:22:42 Error Occurred
25.11.2009 12:22:42 Recover process failed with code 4

Have attempted to restore from the last 15 nightly backups. All result in the above error, “Recover process failed with code 4”, some more quickly than others, none taking longer than 10 to 15 minutes to return this error.

Have then verified each and every backup and tried again. Verification passes with no issues.

Updated to the latest build of Comodo Backup.

Have attempted to restore to mapped network drive, same error.
Have attempted to restore to network drive via UNC, always receiving “Specify a valid directory for the restore location” error before I can even start the restore.

(Searched and Read the forums regarding getting the code 4 error when creating a backup and the necessity of naming a file, not just a path so I actually tried to put a file name there, this resulted in the very same “invalid path” error. )

Searched Forums for “Recover process failed with code 4” and found nothing.
Searched Forums for “ code4” and only found posts/threads regarding this error code and creating Backups, not restoring.

Attempted to restore just part of the backup, same error.

Each time the restore process is attempted, ONE folder is created in destination.

Cannot restore to original location as drive has failed, hence the reason for the restore. Need to restore to new NAS location but seem unable to do so.

Have tried restore process with both Clean Restore Method and Append Files Restore Method, same code 4 error.

Moved one of the .cbu files to a new location on the mapped NAS drive and attempted restore via mapped drive, again error code 4.

Tried to restore that moved .cbu file via “network” in Step 1 “Restore Path” (first selection in Restore Dialog changing the selected radio button from “my computer” to “network” and browsing to the network location.) Same error.

So, finally I tried to restore at least a few files to a local drive and it works.

I have a 56GB backup that I cannot restore to the drive it came from, and only have room on the new NAS, is there ANY way to recover/restore to a network/NAS location?

Please help!

L Durham

Hi ldurham,

Is there any difference in on which credentails Backup is running and the one used to map the external NAS with ? Say drive mapped as Admin and Comodo Backup started as User X

Both were done as Administrator.

As I’m not a developer it’s hard to say what the problem is, but maybe as a workaround you could restore in parts ? Like select a bunch of folders everytime restore to local disk, move to NAS etc?

It should be able to restore to a different target than the source was but it seems it has a bug there…

You could try to post your question in here or link to this post maybe that draws some attention from the dev’s.