Rebuild Repository Folder to Recognize Comodo [Resolved]

I recently sent in a request to Microsoft concerning the Windows Security Center NOT recognizing new 3rd party Anti-Virus & Firewalls installed and WSC still depicting old AV`S & Firewalls that the user had un-installed.

The response I received back from MS was the below which is different from the resolved issue that has been posted here in the forums.

Does this response sound like the correct way to rebuild the Repository folder?

Quote: [ To reinstall WMI issue these commands:

net stop winmgmt
rd %systemroot%\system32\wbem\Repository
net start winmgmt

Reinstalling WMI

You don’t have to reboot for the WMI reinstallation to take effect.] [End of Quote]

Regards, Silverfox

Hi Silverfox

That seems to be the correct procedure for clearing your Repository. It’s normally necessary when your Repository is corrupt. But, did MS say that was the reason why SC was not detecting 3rd party AVs & Firewalls, because the Repository is corrupt?

I can’t check your Reinstall WMI link, because I think it was generated under/for your MSDN login.

Edit: Meant MSDN, not MSN.

This is the same method, only much easier. :slight_smile: His instructions are using the command line instructions instead of using the GUI.

Thanks for the link though.

(B) Lee

MS told me that this way will correct the WSC if the WMI or Repository folder is corrupted, or if you just want to do a fresh re-build to delete old data and have the new running AV`s or Firewalls recognized in WSC.

So I agree either method that has been posted should accomplish the same goal.

Thanks for the replys!

Regards, Silverfox

Hi silverfox,

Thanks for posting this. It is a much better/quicker method than what we were giving before. This will be a great help. :wink:


To make it even easier - see attached ZIP file.

@echo off
echo Stopping Windows Management Service - please wait …
net stop winmgmt
echo Removing Repository folder - please wait …
rd /S /Q %systemroot%\system32\wbem\Repository
echo Starting Windows Management Service - please wait …
net start winmgmt
echo Done!

N.B. The “/S /Q” parameters for the RD command are merely there to supress screen output.

Ewen :slight_smile:

ewen :slight_smile:

[attachment deleted by admin]

Panic, I don’t know how you come up with this stuff so fast, but thanks for doing it. It’s really much appreciated and gives me one more of your tools to add to mine.

Let us all give praise to the dual gods called “Cut” and “Paste”.


Just to let you all know that I did try the “Command Line Prompt” procedure and even after restarting the WMI [net start winmgmt] I still had to re-boot the pc in order to get Windows to re-build the repository folder. No big deal and whether your repository folder is corrupt or you just need to re-build it to reflect your new AV or Firewall it does work just fine with the command line prompt.

Regards, Silverfox :slight_smile:

I have been struggling with this problem for some time now and unfortunatley it doesn’t seem to ever go away.

I successfully did what is described here: stopped WMI, deleted repository folder, re-started WMI. The problem went away … until the next reboot, when it just came back again. I did this some 3 or 4 times with the same result. Please help.

PS. I have recommended Comodo AV to 2 friends who have had the same problem (both had Norton installed previously, while I had Panda).


Do you mean the folder comes back or the problem comes back?

The folder is supposed to come back. The repository holds the info on the Window Manamgement Interface software modules.

Ewen :slight_smile:

The problem came back. Window’s rebuilding of the repository folder does not seem to make the Windows Security center recognize Comodo.

I’ve seen this happen on 3 different installations on 3 PCs.


Comodo antivirus (version 1.1) is not recognised by windows security center. I think version 2.0 (beta testers only) has this, but I have not tried it yet.


What version of the firewall are you installing?

From memory, Security Centre recognition only started with version 2.3.X and higher.

ewen :slight_smile:

On one computer Security Center recognition works just fine without any tweaks.
The other computer don’t recognize CPF or NOD32. After a rebuild of the repositry folder, NOD32 is recognized, but not CPF.
I use the latest CPF on both.
It’s not a big thing, since i have turned off the warnings from security center, and i know if i have a firewall and/or an antivirus program installed…

Sorry… my mistake. I thought I was in the Comodo Antivirus thread. I am having the security center non-recognition problem with CAV.

I was reading postings on that forums and ended up here. Didn’t realize that the topic changed, although the proposed solution in both cases is the same (and I have rebuilt the Repository folder a number of times without that causing it to be recognized).

I guess I will look into this in the CAV forums.


Windows Security Center currently does not report CAVS status. A future version of CAVS should have this.