Realtime protection components are not working on system startup [M2044]

1. What actually happened
After the installation, on every restart, the following message appears: Realtime protection components are not working. Do you want to fix it now?

Regardless of the chosen option, the result is the same: every time computer restarts, that message appears and the software cannot be launched, forcing users to uninstall and reinstall the software, waiting for the next time it will happen again.

2. What you did to cause that to happen, step by step
i) Install CCAV;
ii) Use computer;
iii) Restart computer;
iv) See if message appears. If not, go to step ii.

3. If you repeat these steps does the same thing always happen
No. Maybe the moon phase…

4. What you expected or wanted to happen
A new CCAV update with that bug fixed.

5. Operating system, whether 32 or 64bit, and service pack number
Windows 7 Professional SP1 64-bit (version 6.1.7601)

CCAV full version number (from Help ~ About)
Hmmm… I cannot access menu because the issue. But on Windows Explorer, on “C:\Program Files (x86)\Comodo\COMODO Cloud Antivirus”, on properties of “ccavsrv.exe” and “ccavhelper64.dll” I can see, on both:

  • File version: 1.7.9514.374

  • Product version: 1, 7, 402730, 374

6. Any other security or sandbox software installed now or previously

7. Does this problem occur if you load the default configuration and reboot

8. Any other relevant information (eg Your guess at the reason for the bug)

9. Links to requested files

I’m guessing you can’t open the main GUI to run the diagnostic report? Also can you check your programdata folder for a comodo folder that might have memory dumps with an extension of .dmp. For now I’ll move this to the format verified section.

No, I cannot.

No dumps on ‘C:\ProgramData\COMODO\CCAV\dumps" :’(

I tried everything with no success…

On first installation, that message was displayed, when two system restarts with yes-yes options repaired the installation.

Then, the issue occurred again. So, I tried the repair again, with no success. Then, I tried repair on Control Panel, no success. Then I uninstalled and reinstalled twice, with no success too. Then I went to Control Panel, and on add/remove programs, when repair or uninstall options were chosen, the screen displayed was of the program installation! And that behavior remains until now. I tried to delete manually from register all COMODO and CCAV occurrences, deleted all program files and programdata related to COMODO, removed all related autostart entries and checked on background processes if it rests something… All with no success. I cannot launch GUI, that message always appears and I cannot repair or uninstall from Control Panel, with no dumps on “C:\ProgramData\COMODO\CCAV\dumps”…

I had same problem when I was reinstalling Windows but it only asked me twice, on third restart it was OK and no warning since.

Solved (but monitoring)

I did the following procedure:

  1. Delete “COMODO” folder from “c:\ProgramData” and “c:\program files”
  2. Delete all “COMODO” and “CCAV” entries from system start (with “msconfig” or a 3rd party software)
  3. Delete all occurrences on regedit of “COMODO” and “CCAV” (if a value is found, the container key is deleted; some container keys with “CMD_” format cannot be deleted)
  4. Delete all files with “COMODO” or “CCAV” strings on their names from “c:\windows\system32” and “c:\windows\syswow64”
  5. If some file cannot be deleted, restart system and try again
  6. Install Comodo Cloud Antivirus Beta
  7. Install Comodo Cloud Antivirus (it will recognize it as upgrade from Beta)

Hi kokbira&HaryHr,

Would you like share diagnostic report with us? You can run the command as “CCAV installationpath>ccavsrv.exe -report” to get diagnostic report . We will try our best to fix it.
Thanks for your support in advance!


Please check with version 1.9 build 469 thanks.