Ready to give up on CSC

CRC worked great on Vista, but I haven’t been able to get it to work on Windows 7. It just says “loading . . .” and I cannot scan. It never stops loading. I’ve uninstalled and reinstalled to no avail. There seems to be no support and I receive no answer to my posts.

Hi nahumski,

I know it’s not a direct solution but did you try the latest beta version 3.1.x released yesterday?
To see if that loads correctly on your system? you can find it here


If you have CSC installed, can you check in the process list if Cleaner_Validator.exe is running?


I installed the 3.1x beta and it does not run at all. It went through the initial scanning process, but as soon as I try to open it I receive the message that CRC has stopped working. The Cleaner_Validator process was running, but starting or stopping it had no effect. Incidentally, I have 64-bit Windows 7.

Do you have a list of security softwares you have installed and/or running.
Could some other tool be interfering with the process(s).

I have only Microsoft Security Essentials.

Well then I think Razvan needs to assist you cause I’m out of options here I guess… sorry.

me too. It has never worked for me just keeps loading! I have window XP and Zonealarm antivirus.

I sorted out similar problem by addressing the "COMODO System - Cleaner Service " in local services

It was always showing as stoppedand the program was always stuck on loading

I changed properties to automatic and have never had any further problems with CSC

My version is Beta 3.1…14

Hopethis helps someone out there :wink:


Our QA office is still trying to reproduce this problem, and we hope that in the next update CSC will work for everyone.