Re: Comodo makes Avira AntiVir Consume 47,000K Memory!!

Sorry, I am a bit slow & not very forum savvy.

Tried this. It did not help.

This too didn’t help!

Oops!, …typing error. …I typed scanner by mistake. I meant Guard.

Same here. No difference.

It didn’t help me either. You were able to reproduce this on both your machines right?.. Did you read my thread on Avira Forum? …if it helps. …Could you check if uninstalling Comodo on any of your machines resolves this issue. It does for me. Just to confirm it. Pardon me, I am a novice.

As i said i am a novice, …could i be of any help in determining this module? …i could follow instructions.


OK, Firewall disabled/enabled & Defense+ enabled/disabled (either temporarily or permanently) and all the combinations that I could think of… it did not make difference that I could see.

I’ve read the Avira forums & I can’t even see a drop in memory usage of AVGuard over time like some are seeing there. The next thing I will try is to uninstall CFP & re-install it, so it follows Avira rather than being there before it (I suspect many “no problem” results on the Avira forums could be due to just that)… this will take me awhile (I’ve got to go out).

hmm, I cant seem to find a digital signature for AnitVir Free, cause I was gonna try and add Avira as a trusted vendor to make everything excepted more easily and see if it helps with the issue.

I didn’t notice the issue to much on my pcs with AntiVir Free v.8 and CFP v.3 , but it does seem to make the startup a little long and does indeed stay high on my pc for about 10-15 mins.

Seems to be the case on 3 of my 4 pcs, all use the same AV and Firewall, the only 1 that doesnt produce this issue for me is Windows Media Center Edition.

Thank you all for your testing :-TU
If disabling/enabling firewall and defense+ doesn’t help to solve the problem, but uninstalling of CFP does solve problem, there is some incompatibility issue i guess and no workaround (except radical methods ;D , e. g. playing with drivers, loaded dlls…). Hopefully devs from both sides will address this case.

Hello Yuriy,

How does one forward this issue to the devs at Comodo?

Thanks & Regards,

Hello Kail,

Same here!!

I do see a drop in Memory usage from 46,000K to 8,000K in approx 15 mins. Here I am referring to the Memory, & not the Virtual Memory. (Virtual Memory remains constant at 66,500). Hope you too are referring to just Memory usage.

On my machine, It was Avira 1st & then Comodo. I think I should try uninstalling & re-installing Avira.

I would advise you to check avguard usage after uninstalling CFP & before re-installing it.



You are quite right… at one point yesterday I actually started looking at the Virtual Private Bytes, rather than the Working Set Private Bytes because they were the same (which they are not any more!). Doh! I will have to re-do all my testing (since I can’t be certain what I was looking at now). Just as well, since I can’t do the uninstall/install test anyway (yes, I was going to see what AVGuard was doing after the uninstall). I can’t currently get CFPs download page to load (again) & I need the full install since I only have updates.

Well, I added cfp.exe to the exception list for process guard (in guard settings) in Antivir and the whole Comodo Firewall folder to the exception list for file guard (in guard settings) and everything seemed to boot and work faster and it didn’t bring avguard.exe past 12,600k.

I like the way its working like this atm so ima just leave it until they make a fix and then I’ll remove the exceptions again

Myself & Kail have already tried that. It did not help us. Did you check the consistency of the values you have stated above?. …by rebooting the machine 2 to 3 times? …cause even mine stays at 12000K sometimes.


Maybe the problem is Avira and not COMODO.

Avira Premium 8 with web guard and Comodo 3.0 working great on my end. There are several things to add to the firewall and D+. Already posted it in another thread. See pics. Not a bug on my end. Look at reply #6. Avira with its 5 processes use around 22K for me.

Well, it seems now all my pcs have this issue with 47,224k being used up. And it seems that it happened after the product update (open AntiVir go up to Update and click Start product update and it installed new copies of avguard.exe, setup.exe, and some other file.)

Comodo listed them in pending files on all pcs. Not sure when this was released but I do notice the 47,000k issue on avguard.exe, seems that the product update has dilemma with Comodo Firewall. Cause after I restarted all the pcs multiple times, they experienced the 47,000k hang. My CFP icon on all the pcs seem to take extremely long to load now, and it was fine before the product update.

Hello Vettetech,

Thanks for your advice, but have already tried that. Re-confirmed it after checking the pictures on the thread you have mentioned. But still no help. Could you offer some other advice as to what could be the culprit. It seems not everyone is experiencing this issue. & some have not bothered to check their Taskmanagers.
I have 3 partitions on all my PCs. Could that be the cause? …but then avguard.exe is within normal limits without comodo.
Could RAM be the culprit. I have 512MB installed on all PCs.
I have already posted this issue on Avira Forum.

But no help.


Hello FFkefka77,

Shouldn’t be saying this, but i am so relieved to learn that people are bothering to check their TaskManagers & reproduce this issue.

I have 3 partitions on all my PCs. Could that be the cause? …but then avguard.exe is within normal limits without comodo.

Could RAM be the culprit. I have 512MB installed on all PCs.
What RAM are you using on your PCs?. My Friend is using a Toshiba Laptop. He has 1.5GB RAM installed. He is not facing this issue. Futher, the umbrella icon in his TaskBar notification area opens almost instantly. On mine it takes quite long.

Other than that, I have tried every trick possible. It just does not help. Only solution that seems to be working is to uninstall comodo. So I guess we will just have to wait till the Comodo or Avira guys come to our rescue.


Avguard in my taskmanager is only using 14,000 K. Sometimes only 12,000 K. I am using Avira Premium 8 not the free version. Did you add all the Avira files I posted in D+?

Hi Vettetech,

Yes I did add all the files (except avwebg…) as that file does not come in the free version.
If you don’t mind, can you inform me the following…
On your machine, is the consumption 14,000K in the start too., I mean when Windows has just finished loading.
Does the umbrella icon open immediately as it is listed? …or does it take a few seconds to open?
…& what RAM is installed on your machine.

Do you have any other suggestions for me?


I have 2 machines. I laptop and one desktop. Both with the same set up and both with 2 gigs of ram. The umbrella sometimes and sometime it doesn’t open. This is a known Avira problem. I never paid much attention to ram usage when you first boot up cause naturally its gonna be more then after your pc has been up for awhile. Why dont you try Avast instead. Its free also and just as good as Avira Free.

Indeed 2 pcs have 2 gig ram and the laptop has 1 gig ram and the startup just takes a little longer but that’s no biggie since in the long run it doesnt effect my gameplay or anything so I can deal with a few minutes of 50 ram being consumed for a while