RE: Antivirus Update Errors


We have CIS installed on 3 computers here - 2 Windows 7 and 1 Windows XP.

I have found out today that the Windows XP system has not been automatically updating its antivirus definitions since 11th November.

It has been downloading 211MB every few minutes every time the update fails - meaning that we have just been hit with a massive bill from our ISP for going over our download limit.

It gets to 90%, says that it is finalizing, and then a few minutes later says the update failed and for me to check my internet connection.

There does not seem to be a problem with my internet connection, as CIS has downloaded about 40GB of unused virus definitions in the last 3 weeks.

I have turned off automatic updates for now to stop being hit with any more ISP charges, but wonder what I should be doing to solve this update problem.

The computer in question is running Windows XP Service Pack 3.

The CIS version it is running is 5.10.228257.2253

The virus database version installed is 20053.

As I said, both Windows 7 systems seem to be updating OK, although they are using slightly older versions of CSS.

Any help would be much appreciated.

Thank you for your time.


I have subsequently followed the instructions from here…

… and installed the most up to date antivirus database without any obvious problems.

However, although the auto-update no longer tries to download 211MB every time, the update still hangs on the “finalizing” stage of the update.

Any help would be much appreciated.

Thank you

There are various possible solutions in Comodo AV Version 5.12.256249.2599 Won’t Update. My bet would be on the solution where you clean the temp folder of CIS for the av update which is situated in the Quarantine folder. It requires a take ownership procedure to be able to access those folders.

Hi Eric,

Thanks very much for replying.

As per your suggestion, I will have a go at cleaning the temp folder, and report back with the results.



I tried

  1. the delete bases$$$.cav trick

  2. stop/restart cmdagent.exe trick

  3. deleted the contents of the temp folder in the quarantine folder by booting into an admin account in safe mode

but still get the failed to update error.

I do not know whether this would be relevant, but the CMOS battery of this computer did fail a few months back, which set the date back to the year 2000.

Obviously this has been replaced and the date reset, but could this have been the cause?

Thank you for trying to help.