[Q] CIS 6.1 Installer or Updater


The Installer or Updater rule is not working like in CIS 5.x. Is this a bug?


still not working in 6.1.276867.2813…

What is not working? Can you describe the problem in more details?

I have set a custom app launcher called “Launchy” as “Installer or Updater” in Defence+ App rules so any application that is launched from Launchy is treated as safe thus ALLOWED to do anything and there AREN’T any defence+ access prompts. Same occurs with several IDEs like SharpDevelop, Codeblocks etc… With v5 works fine, with v6 its not working as I’m getting defence+ prompts for every app.

Could you try to use Windows System Application policy instead of the Installer/Updater policy?

The Windows System Applications works as intended but not what I want. I prefer the Installer/Updater policy so I wouldn’t get any defense+ access prompts for my compiled apps. With v5 the Installer/Updater policy works as intended so i guess I’ll move temporarily back to v5 until this i fixed. Thanks for your time.

Should I report this in the bugs section?

It is worth a bug report I would say.

I’ll add my problem here, since it appears to be similar.

HIPS Enabled, Safe Mode. All other settings are pretty much at their default values - I don’t recall making any changes.

I get the following Defense+ Events:

Prog A Terminate Process Prog B

Prog A Access Memory Prog B

Script C Access COM Interace SVCHOST.EXE

All of the above are in Trusted Files.

I added Prog A and Script C to HIPS Rules as “Installer or Updater” - but no change. I then changed them to Custom Ruleset, with Access Rights > Process Termination=Allow for Prog A, and Protected COM Interfaces=Allow for Script C, but still no change.

No change if HIPS is Disabled. Tried rebooting, but still the same.

I did not have these problems with CIS V5.

After reading this post, I tried “Windows System Application”, which works for my purposes. Definitely looks like a bug - should be easy to fix, no? :slight_smile:

Thanks for confirming that I’m not the only one :slight_smile: Can a moderator move this to the bug section?

Please create a new post for this bug in this section of the forum. Be sure to follow the format provided in this post.

Thank you.

It looks like there is something not right with the Installer/Updater policy (Windows System Application policy works and does basically the same). Please consider filing a bug report on this.

Hey, I just noticed that there is no entry for “Installer or Updater” under Rulesets. Shouldn’t we see one? ???

Not sure why it’s not there. It is still available as an option in D+ alerts. May be Comodo is protecting t by not putting it under rulesets…

I have just posted a bug report. Thanks :slight_smile:

Ha, I was feeling lazy, but I knew that if I waited long enough, it would get done :slight_smile: