Purge doesn't purge enough


  1. What you did: Defense+ tab / Computer Security Policy / Defense+ Rules / Purge button
  2. What actually happened or you actually saw: After a few seconds, a list of no longer existing files is displayed
  3. What you expected to happen or see: The list is built only from the entries listed in Defense+ Rules. It’s good but it should also be built from the “Run an executable” entries of every primary entry. For example, the “Run an executable” for explorer.exe contains 129 allowed exe and 3 blocked exe in my case. Among these 129+3 files, some are no longer existing files, but are not listed by Purge. They should be.
  4. How you tried to fix it & what happened: Too long to fix manually :frowning:
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: N/A
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): N/A
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: see #3
  8. Any other information (eg your guess regarding the cause, with reasons): see #3

B. FILES APPENDED. (Please zip unless screenshots).:

  1. Screenshots of the Defense plus Active Processes List (Required for all issues): really useless for this report
  2. Screenshots illustrating the bug: attached
  3. Screenshots of related CIS event logs: really useless for this report
  4. A CIS config report or file: ?
  5. Crash or freeze dump file: N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: 5.8…2131


  1. CIS version, AV database version & configuration: 5.8…2131, no AV
  2. a) Have you updated (without uninstall) from a previous version of CIS: yes
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: no, pb not related to upgrade process. Pb existed in CIS 5.5 and previous versions.
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): yes: “create rules for safe applications” activated
  5. Defense+, Sandbox, Firewall & AV security levels: Defense+ paranoid, Sandbox disabled, Firewall custom, AV not installed
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 64-bit SP1, UAC ON
  7. Other security and utility software currently installed: Avira AV
  8. Other security software previously installed at any time since Windows was last installed: none
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: none

[attachment deleted by admin]

Please note the reason this post is here and not in the bug reports forum.

We have moved your post to:

  • The Wishlist as this seems to us a wish for functionality outside the current design of CIS rather than a defect or deficiency in the current design

Can this restricted behavior be added to CIS online help?