Properly silent Autosandbox

I’ve complained over this several times and despite Egemen assuring me it has been fixed, IT HASN’T been fixed at all. So i’ll do it again in a hope it’ll actually get fixed in v6.3…


  • CIS not asking me about privilege elevation options and auto sandboxing unknown files. If file is signed and on TVL, don’t display ANY popups to me and give it full rights. If the file is unknown, sandbox it directly and don’t ask me for elevated privilege (like it does now).

By unchecking (disabling) option “Detect installers and show privilege elevation alerts” (only this and nothing else)

Because options:

  • Trust applications signed by trusted vendors
  • Trust files installed by trusted installers

Are enabled and shouldn’t be overriden by unchecked “Detect installers and show privilege elevation alerts”.

Unchecking “Detect installers and show privilege elevation alerts” breaks TVL and CIS will just sandbox even installers that are signed and on TVL list which otherwise don’t ever get sandboxed.

Try installing Burnaware Free program with enabled and disabled “Detect installers and show privilege elevation alerts”. Until it gets installed without getting sandboxed in either case, you haven’t fixed anything.

I can’t possibly write this any more clearly (for the hundred time already). Now please fix this ■■■■ thing properly already.

Egemen did respond:;msg691132#msg691132

I too hope for a resolution :slight_smile:

He didn’t answer ANYTHING. “Detect installers and show privilege elevation alerts” setting is broken and he is consistently refusing to admit it.

If this ■■■■ is enabled, you get the popup about elevated privilege. If you uncheck it, entire TVL system gets wrecked and broken as it DOESN’T function ANYMORE (even though it should because other stuff related to trusted installers is still enabled).

Installing Burnaware Free is the best example of how it gets broken. But i guess he just can’t be bothered by simply freakin trying it himself.

Will the setup be sandboxed or will the program itself be sandboxed?

For me the setup doesn’t get sandboxed with the setting on nor off, however you might mean the actual program it installs but I’d prefer not installing it unless this is what you mean.

Edit: I also tried installing it now and no matter what the option was set to the program was able to install and run outside of the sandbox, so I’m not having the issue you are having. :-\

Could you provide us with quotes where he actually said it was fixed? It is not what I recall. Your problem is going to be addressed:

Egemen did answer. There is a fix but needs some work on the GUI to make the fix complete.

Your anger and frustration are misdirected after egemen’s announcement. They were already in the past where you did not get the fix as fast as you wanted it.

It needs ABSOLUTELY NO fixes inside GUI. It’s broken underneath, not on top. Geez, am i the only one speaking English here!?

Better than you do because I am non native speaker… We are told we speak better English by native speakers than they do … :wink:

But seriously.

The part in blue tells me it is fixed. The rest that it is not ready for the limelight because they also need to adapt the GUI.

What the hell do they want to fix in GUI !? There is nothing to fix in the GUI. GUI is not the issue at all and never was. What that control does is broken (the stuff underneath the checkbox option) and you don’t have to change bloody GUI to achieve that.

One more time…

Unchecking “Detect installers and show privilege elevation alerts” (only this and nothing else) negates otherwise still checked (enabled) “Trust applications signed by trusted vendors” and “Trust files installed by trusted installers”.

That IS the whole problem here. The “Detect installers and show privilege elevation alerts” doesn’t only control privilege elevation popup, but also seems to disable “Trust applications signed by trusted vendors” and “Trust files installed by trusted installers” (even if they are still checked in the GUI). Which is just dumb and makes no sense. I just don’t want to be asked about stupid privilege elevation rights, i want CIS to directly sandbox (isolate) unknown apps like it is set to do as default if user doesn’t select anything in the elevation popup. But if they are signed and on TVL, i want that CIS automatically gives that app full unlimited rights.

Instead CIS doesn’t do that. It sandbox everything because it just ignores TVL list. And Burnaware is the easiest way to test that. It’s signed and on TVL list and if you uncheck “Detect installers and show privilege elevation alerts” its installer components will get sandboxed even though they shouldn’t because of the other two settings “Trust applications signed by trusted vendors” and “Trust files installed by trusted installers” should automatically give the installer full unlimited rights.

I’ve explained this so many bloody freaking times it’s getting ■■■■■■■■ now. And this isn’t some tiny non issue. Because of it i CAN’T install CIS on systems used by clueless people. If i would, they’ll just click the green UNLIMITED RIGHTS for every unknown thing and make the whole D+ pointless. And i don’t want to put it in full silent mode because then stuff just doesn’t work and user has no clue that CIS actualyl blocked something.

If you people can’t freaking understand this after 50 explanations in 25 different ways, then this has to be the worst company to customers communication i’ve seen in my life and the worst QA in decades. It makes me wonder if even people behind the program itself have any clue what they are coding. Because from what i can see here, they don’t even understand their own protection system and how it should work to be the most user friendly with no protection compromises.

Personally I’m not having this problem, I’ve tried what you said with Burnaware free and some other programs but I can not re-create your problem so to me it seems like a local issue and not an issue with CIS as a whole.

Have you tried a complete re-install of CIS? Have you tried this on different systems?

It was a clean install on Win7…

Issues can occur even on clean installs.
So that is the only system you’ve tried it on and you haven’t tried a complete re-install? Just wondering, it could be a problem with your CIS, on the other hand it could also be that the option actually works normally for only a limited amount of people which I am part of. shrugs

Rejzor, we hear you and understand you. You have explained it multiple times and even filed a bug report.

According to egemen the solution is on the way. Apparently it is fixed in the code but the waiting is for placing check boxes for the new settings.

Are you not happy with the solution egemen is offering?