Processor load problem

After installing the last update (version I noticed the processor (Duron 850 MHz) is too loaded. Here is the image ( showing the moment of switching from Block all mode to Custom. Now I have to block all trafic when I want to record video on my tv-tuner (else it drops frames) and switch back to custom level after recording.

Hi and welcome to the forum!

First of all, this may be a spike and will go down after a bit. Even on my pc when opening a small GIF image I get up to 69% spike to 79 and after gif is going\opened it calms down. Also, you have an 850 processor, it’s a bit old now my friend. I have an old AMD 850 best for it’s time and still for doing what you are doing, I would have to close some things down as well and my son usually does since he uses it. When he tried video imaging or anything like that, he darn near gave it a heart attack. How much ram do you have? If you have less ram and 850 , xp you are already scraping bottom. Let me know the pc specs , this will help a lot.


Paul, I agree it looks like my computer isn’t up to the tasks I give him, but this impression is wrong. I have 1 GB RAM and when recording video on tv-tuner, processor is loaded to about 70%. Hard disk is fast enough (ST3200822A) and everithing was OK (no frames were dropped at all).

I think maybe you are right, I am asking for help too early, probably I have to wait and see - maybe this is temporary thing, maybe it will go by itself…

Hi , no, you are not asking too early, you have an issue and did the right thing. These spikes do drop and even on my 850 it takes a bit and needs time to drop the processing. If this doesn’t work please post back. :wink:


The thing is, Windows Task Manager shows cpf.exe uses up to 98% in peaks. Looking at activity log I can see, when a serie of packets comes, which are blocked, processor is loaded to max.

So you are getting the high CPU usage then? A constant? Others are getting this as well and can’t figure out where it’s coming from. I often wonder if the nic drivers or a bad nic would aid in this and in the past it has, not with comodo but other softwares. Try unplugging your network cable for a minute and see if the spikes drop and post back.


It may be. My nic was changed just a few days ago, internet came back and I downloaded Comodo update.

I see. Why was it changed? Also, do you have the latest drivers for it? I have seen nics cause a lot of grief for people. If you have another, it may be better to try it and then see how things react. Also, was the update for a current 2.4 or 2.3 ? It still may be tied in to 2.4 but I would definately think about the nic too. I have to get to bed, it’s the wee hours here and hate to drop this but either that or I drop to the floor. ;D Please post back, if i’m not here, someone else will help you out and have some other ideas i’m sure.

Take care,


Thank you for help, Paul. I started to experiment and to make a long story short now I think the problem was related to too many programs loaded into memory. Also now I better understand how Comodo uses processor time and will turn it off during video recording to make my recordings smoother.

cpf.exe using up cpu%? I bet it’s the logging. Try to temporarily disable it and see what happens.

Yes, soyabeaner, that’s right. When I disabled network logging, Task Manager shows quite different picture. I should guess it for myself. Now all problems are gone.



I have to confirm this problem. I have computer on busy to the world open network with many multicast streams running around so firewall have to logs quite a lot of entries (sometimes several per second). I noticed strange CPU load on my machine (almost 100% of one core of Core 2 Duo). Strange is that the load is not done by any process but by system itselfs (core times). I was also suspecting firewall logging but until now I didn’t have enough time to play with it. Now I turned off logging and core times load is gone. Also strange is that it do not load cpu always. It happens sometimes that after reboot everything works fine.
I guess based on the picture vadim post that his problem is basicly same.
Let me know if I can somehow help to identify this problem more.


Nice tag soyabeaner! So the network logging is causing some issues then but why only on some computers? I can’t see CFP over logging unless something is giving it a reason to but I suppose that’s for the support team. Good catch. :wink: I’ll remember this for next time.


I’ve known about almost all conditions causing high cpu usage, for both cpf.exe (logging) and cmdagent.exe (monitor dll injections among others), but I’m starting to get tired of posting the same info (:TNG).

If you set the logs.log file (C:\Documents and Settings\All Users\Application Data\Comodo\Personal Firewall\Logs) to read-only, you can still keep the logging option on and it shouldn’t cause high cpu usage with cpf.exe. However, once you exit CFP the log history is gone (or to whatever you last saved it).

Also awaiting the ticket I filed weeks ago.

:-[ same things here : high cpu load from cpf.exe is causing dramatic lost of fps in games… guess what ? quitting comodo restore the original fps.
(with comodo last update)

Same here. I posted here,6433.0.html a similar problem. I disabled log, but problem resolved 50%. Still i have repeated spikes of CPU usage 60-100%. With previous version of COMODO firewall all works fine…
Other firewalls log the network traffic , but not use 100% of CPU for that…

That thread basically leads to another thread with me in it ;D. Is the remaining 50% due to cmdagent.exe?

No. It’s weird but cpf.exe it’s the only executable with ~12 -20% load in peaks , but if i take a look at processor performance - is at 98-100% peak. If i shut down completely the firewall cpu usage drop at 0-3%, or if i disable network monitoring - the same results, processor usage went’s to normal…

That is weird. Logging is the only culprit I know of that causes high cpf.exe usage -

other than with the connections window opened with many connections running (which isn’t nearly as high as the logging issue). Another one is if you scroll up and down in the Component Monitor list, but such actions/results are expected.

Yes, my mistake… Finally from logging was the problem. So vith this ultimate version iti is a big problem with cpu usage when any logging is activated on some circumstances, or some configurations… I hope in next version this problem will be solved somehow :Beer