Problems with the signature in Outlook

I just registered for / received a personal email certificate. The 1st test message I sent from my work PC(sent from my personal email to my business email) worked great. Outlook showed that it was signed and the signature was valid.

I exported the certificate, emailed it to my home PC, and imported it there. When I sent a test message from there to my business email, I received the email, but this time Outlook is complaining that there are problems with the signature.

I tried sending duplicating my 1st step. From my work PC, I tried sending an email from my personal email account to my business email account, and now I’m getting the same problem as my home PC. Outlook is reporting problems with the signature.

Work PC is Outlook 2013 with 2 Exchange profiles running (home / business). Home PC is Outlook 2010 with 2 Exchange profiles (home / business).

When clicking on the yellow triangle error, the error message says → “The digital signature on this message is Invalid or Not Trusted.” Drilling down I get a message that says “The message contents may have been altered.”


One quick follow-up. From both my work PC and my home PC, I sent a test message from myself (personal email/signed) to myself (personal email/signed).

It worked on both PCs. So - I’m going to check the provider who does our spam/antivirus filtering at work to see if they might be tampering with the signature in some way. For reference, my personal email is hosted with Office 365. Business email is onsite Exchange 2010 with 3rd party spam/antivirus filtering.

Any other thoughts would be appreciated!

One more item to add. Send an email from my personal email/work PC to my wife’s email. Checking it via Office 365’s OWA app, I get the following information: “The digital signature on this message isn’t valid or trusted. The server couldn’t build the partial certificate chain.”

That’s after downloading/installing the OWA S/MIME control…


Sounds like you exported it OK, but didn’t include all the certificates.

First thing to check is that you exported it with all certificates, instructions can be found here:

Then do the import again and test.