Problems with CMF and Open Office

The two seem incompatible with 100% CPU usage as soon as I try to Open office.

Removing CMF cures it.

Try adding the Quickstarter and the EXEs to CMF’s exclusion list.

For me the fly in the ointment seems to be stclient_wrapper.exe
Opening Open Office Org 3.0 causes a constant 50% spike in CPU usage.
If I then kill the above process with process explorer, the program runs at virtually 0% CPU usage.
This is with both CMF v2.0.4.20 and CFP v3.0.23.364 running.
Nothing detected in both firewall and defense+ events.
In my case I think that it may have something to do with the firewall as this did not occur with the previous version of the firewall.
There are a couple of posts about it in the Open Office Forum:

Clicking on the link at the bottom of the first post will bring you to the second.


That was exactly my experience. Running CMF v2.0.4.20 and CFP v3.0.23.368 here and as soon as I opened OO stclient_wrapper.exe went to 100% CPU, as soon as I killed that process everything opened fine.

I have removed CMF for the time being.

I had to remove CMF as well.
Simply exiting CMF did not solve the CPU issue.
My initial speculation about it being due to the new version of CFP was wrong.
However, this resolves the anomaly with my observation that there was not any firewall or defense+ events.
(If it were due to CFP one would expect there to be something in the firewall or defense+ logs.)
Therefore, I can confirm your conclusion about removing CMF.

Additional info for the developers:

After removing CMF and opening Open Office the stclient_wrapper.exe file is not executed!
Open Office runs normally: soffice.exe and soffice.bin are shown in process explorer.


This is strange. I use CMF, CFP (latest) and just tried opening Open Office whilst monitoring it and fund a maximum of 33% CPU usage. So I wonder if there is some other reason as well.
XP Pro SP3 2.8Gb Del with 512Mb memory.

Edit: This is with Open Office 2.3. There may be later updates, but I find it tedious updating that program every time a new version comes out.

I had this problem with Open Office 2.4. It would not start up and had very high CPU. Solved it by adding stclient_wrapper.exe to the exclusion list for CMF. I had a similar problem with a Python application.
I am running CMF 2.0.4 and CPF 3.0.24 and NOD32 V3 on Vista 32bit.

They must have added stclient_wrapper.exe in 2.4 I did a search and did not find it running 2.3 they do an update every two weeks sometimes so it is a job keepng up.

Thanks for the info Dennis, I’ll stick with OO 2.3 then; does everything I need, and only use it a couple of times a week. :slight_smile:

Using OO 2.4.0 here. XP Home SP3.

I reinstalled CMF and added stclient_wrapper.exe to the exclusion list. problem solved, stclient_wrapper.exe no longer runs when i open OO.

Cheers guys. :■■■■

Using OO 3.0 beta and XP Pro SP3

I also reinstalled CMF and added stclient_wrapper.exe to the exclusion list.
It also solved my problem.
stclient_wrapper.exe no longer runs when i open OO.

However noted a red x at the bottom of CMF stating:

Driver not active! Please reinstall product.

Reinstalling CMF still resulted in the message being displayed.

However Process Explorer seems to indicate that cmf.exe is running with a constant 2.9 MB showing under the Private Bytes History graph.

Has anyone else noted the Driver not acitve! Please reinstall product. message in red at the bottom when you open the CMF?


I’ll answer my own question!

Yes: There is a thread about it in the help section:


I just stumbled upon this thread and realized that the previous posts have pointed me to a solution to a problem that has been bothering me lately, namely the slow starting of OO.o 2.4, especially Calc. I have followed the above suggestions and have added the component stclient_wrapper.exe to the CMF Exclusion list: the problem has gone away.

I do NOT get the “reinstall product” message in CMF so this is a separate issue, I think.

For the record, this is the seventh item added to my CMF Exclusion list. The others involve DropMyRights, an obscure part of Acronis TrueImage, three Cygwin procedures, and MS dumprep.exe. All signal there need by pinning the CPU at 100%, sometimes for a finite time (the current case), sometimes “forever” (the other six).

Thanks to the previous poster for finding this!

i’m glad i found this thread the open office conflict was causing me a major headache and i put it down to yet another issue wth the latest comodo firewall update. good to know i can reinstall and keep cmf running :slight_smile: will the next update to cmf fix the issue?

Note for developer:

It seems issue described by tcarrbrion here (about stclient_wrapper.exe [part of OO 2.4] consuming 100% CPU) is not only CMF related issue. If CF (Comodo Firewall) library guard32.dll is not loaded in memory at system startup, issue is gone, at the same time CMF is active and running without any exclusions. Related thread.
Windows XP SP3 x32 (fully patched), CF 3.0.24 + CMF running in memory.

Where is the exclusion list please ?

Hi alithew,welcome to the forums.

To put something in the “Exclusion list” right click on the CMF tray icon and OPEN.Now you will see on the main interface “Exclusions”,click on it and then “Add” where you can select it from running applications or browse to it.


uh… I believe I’m blind or completely stupid but I see no “exclusions” option. Is it in the summary tab ?

There is no summary tab in Comodo Memory Firewall.

However, there is a summary tab in Comodo Firewall Pro.

It is easy to get the two applications mixed up.


oh my god I though you were talking about comodo firewall cause when I turn defense+ off (not only disabled) there is no problem left with open office
Excuse me for the confusion

edit: hmm I think there is something between CMF and Defense+, cause if you close CMF OR deactivate permanently Defense+ then open office starts. There’s another thread talking about that, but it doesn’t point defense+, it says that disable defense+ changes nothing, that’s rignt, but deactivate works (need to reboot)