Problems installing on Windows 7 x64 related to registering "AV shell" [NBZ]

First Before I post the “form” I want to say that did have 5.0x installed and it started after I uninstalled it so I could “Clean install” 5.3x… I do have (seperate installer obviously) 5.3x installed on my Windows XP 32bit laptop and have had NO ISSUE. I do not want the AV installed (although I have tried it and the problem still occurs) … just Firewall+ and Defense+ …

The bug/issue

  1. What you did: Removed Comodo IS (Firewall and Defense+ … no Comodo AV installed) 5.0x in order to “clean upgrade” to 5.3x on my x64 bit Windows 7 computer… I have gone in registry and searched my hdd for leftover entries after the removal many times and have not found too much that the uninstaller did not remove automatically anyway … I have posted and searched this forums and used almost any of those “uninstaller” scripts and followed the instructions on how to use them … I did (with 5.0x ) have COmodo installed and had no issues or odd behavior (whatever that means) with it … just downloaded the 5.3 installer for 64bit and decided “eh … why not upgrade?”

2. What actually happened or you actually saw:

Install (even after the steps I listed above) always hangs on “Registering AV Shell Component”

Event log results is:

Product: COMODO Internet Security -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action RegisterCavshell, location: regsvr32.exe, command: /s "D:\Security Programs\COMODO\COMODO Internet Security\cavshell.dll" 

Yes I have tried to install to default location to … same problem …

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:

Your set-up

  1. CIS version, AV database version & configuration used: Happened first with 5.3’s x64bit installer … than even after steps to remove and clean registry (see above … I am not going to spam the same answer) the 5.0x installer did the same thing (the one that had previously worked fine) …

6. OS version, service pack, number of bits, UAC setting, & account type: Windows7 x64bit Home Premium, some (but maybe not “ALL” patches), UAC is off (I trust Comodo’s Defense+ more than UAC anyway), Admin level Acct.

7. Other security and utility software installed: Win Patrol, Avira Antivirus, Malwarebytes (Free Ed.)

[attachment deleted by admin]


  1. Please disable Win Patrol, Avira Antivirus and Malwarebytes before you installing CIS
  2. If it isnt help, please create and attach log files as described here: Please read this before posting an installation problem - Install / Setup / Configuration Help - CIS - Comodo Forum

Ok … I not only used Autoruns to disable “startup” items of those apps, but I used them to disable any “Driver” or “service” related to those apps as well … (and since then re-enabled them) … still the same exact error … related to “CAVshell.dll” (Comodo’s) … even when I am just installing the firewall

I have created a few logs and honestly forgot which one is which (haha) … so I included both

[attachment deleted by admin]

Log file tells installer cannot register module becouse of access denied. There are can many reasons:

  1. You account havnt privileges to register system modules
  2. Installer running in sandbox
  3. One of the required system modules are miss or moved (some of security products can move them. I dont know why - )
  4. Some of installed security products blocks or delete cavshell.dll
  5. etc

You can check and try to manually register module.
When this error is shows, dont close a message, open command prompt (cmd.exe) and go to the installation directory and type (first be sure cavshell.dll is exists in this directory):
regsvr32 cavshell.dll

(just FYI)

  1. This IS the admin acct for the pc (its only me on it )
  2. I HAVE TRIED creating a new acct (admin acct) and disabling those progs (autorun method) and then installing … same issue
  3. I just tried your suggestion and I will include a screen-shot of an additional message I got this time, while running that command

I really do not like not having any firewall (or Defense+ style program) on this computer at the moment but to be honest I am running out of ideas …

I want to be clear i am NOT TRASHING COMODO … this is being caused by some silly registry hive permission issue … or something else I am overlooking …I have 5.3 (from a different installer obviously … this is 64bit and the 32bit for my other pc) installed on my old xp laptop and there was no issue … one of the reasons I keep trying to figure this out (other than my persistence) is the fact I love Comodo. I will look at registry permissions again and see if I spot the root cause of all of this … I will be sure to report back if I find out what it is, to help others who may be having same issue

oh yeah …4) The only “sandbox” program on this computer was Comodo’s

I am (after i post this) going to search for that screen-shot and see if I can find out any tips on what it means … I may even try a SFC /Scannow to fix any missing components … I have a ton of apps and so far the install of Comodo is the only thing “fishy” I have noticed, but I have not gone into “everything”…

Again, thanks to Comodo support and all the forum posters (various threads) that are trying to assist … it is appreciated

[attachment deleted by admin]

just one of many with the same solution … gonna try that solution … (I) have a few things to do but i will report back either way

hope its not going be a domino effect (one error fix leads to another which leads to another … ) haha… I have had those in my experience over the years before …


Followed those instructions and they both were successful … i tried install (i forgot to disable all items related to other security software in autoruns though) … same problem … still get that same message when i try to register cavshell.dll manually … .will disable all items (autorun method) and re-try … later … i hate not having this issue figured out/fixed but I have a ton of stuff to do and ATM i feel like i am wasting time … .will come back to this issue later

ok, there is OLE path problems and there is lot of reasons of this problem and lot of solutions to fix it :slight_smile:
try this:

You have a Win7 x64, right?

open cmd.exe with elevated privileges
type a command
cd /d %windir%\system32
Again, you need a cavshell.dll (you can just copy it to any location for testing)
For example, your copy of cavshell.dll located at the c:\ disk and full path is c:\cavshell.dll
Now type next command in the cmd.exe:
.\regsvr32.exe c:\cavshell.dll

Note, the most important in this command is a .\ (dot-slash before regsvr32), and the current cmd’s directory must be %windir%\system32.
I assume there is just an wrong PATH variable.

If this helps, immediatly do the next command (do not close cmd.exe and do not change it current directory):
.\regsvr32.exe /u c:\cavshell.dll
(If registration was successfully you need to unregister library, overwise system remember wrong dll path)

And… please type next command and copy results here:
echo %PATH%

hope this helps…

and… one more question
you said you account is in Admin group
but in any case in Win7 OS regsvr32 must be running with elevated provileges
so cmd.exe must be launched using “Run as Administrator” menu item (UAC messege must be shown)
Does you?

More solutions:

sorry i haven’t replied in a day or so … been really busy

I have tried another version of 5.3.xxxx and it had the same issue …

I have followed the steps in the "OLE path " Post and still got the same error (as when i tried to register cavshell.dll right after the installer’s error message, but the installer still open) (I posted it a few posts up … i tried to register and unregister other dll’s the same way and they worked either way with regsvr32 “successfully” …

C:\Windows\System32>echo %PATH%
D:\Program Files (x86)\PHP\;C:\Windows\system32;C:\Windows;C:\Windows\System32\W
bem;C:\Windows\System32\WindowsPowerShell\v1.0\;D:\System Tools\Archivers\Univer
sal Extractor;D:\System Tools\Archivers\Universal Extractor\bin;D:\System Tools\

and YES it said (after i ran it with “run as administrator” (even though this acct is an admin acct) ) “Administrator Command Prompt”

I have not always (before every install trial) gone in and disabled all startup items, drivers, …etc etc in auto related to other security products (as suggested above… since even when i did that the installer still didn’t work)

I repeat i did have 5.0.x installed (before all of this happened) on this win7 64bit pc and it worked without any issue … it was when i uninstalled 5.0.x to “clean upgrade” to 5.3.x, is when the problem started … (I say this to show that I did have Comodo IS 5 installed on this pc and it did work )

Of course even though I image the drive (driveImageXML), I dont “typically” use restore points, but as soon as this started, I tried a restore point but that didn’t help my problem (of course it didn’t … .I wouldn’t be on here if it did :stuck_out_tongue: )

Thanks again for all your help

Well, I cant say this issue is “fixed” … installer still fails at the same error, however I saw this post and took that method

(Hard Restart when error comes up) … I restarted and COmodo is installed … I even did a “Comodo Diagnostic Check” and it said it found no problems at all … Comodo is the way it use to be (5.3 now) … PC is not lagging, boot time is not “5 times longer” … So far (Crossing my fingers) it seems to be ok now, but I know I AM NOT SUPPOSE TO HAVE TO DO THAT to get Comodo installed … If i have to install 64bit Comodo that way from now on (at least until my next reformat …) … fine …

I want to repeat how greatful I am for the help and I know (i am 99.9 sure) it (the issue) has to do with my system and some setting on it … I certain threads blaming Comodo… I still dont know exactly what is causing the cavshell.dl issue, but I just happy :smiley: that I have COmodo 64bit installed again

again … .thank you all for the help

Thanks for trying to help find the cause of this problem.

As it has not really not been fixed moved to verified.

Please post back if you ever find the cause of issue.

Thanks again for all your efforts, and to the Staff member elGeminy for his assistance.