problem with sandbox

I installed the Comanche 4 game. I played it with no problem during a few days, but when CIS showed me the sandbox alert asking if I want to put the xxx.tmp file (a file for playing a video of introduction) at the sandbox, by ignoring it, I can’t play this game anymore. I ignored the alert and continued playing. Later, by running the game again, the executable file dont’t run (first it runs the video and then it runs the executable). The task manager shows c4.exe (executable) and xxx.tmp files in the process list, but a pair of seconds later, they disapear and thus the game won’t run.
I reinstalled the game and choose “don’t isolate it again”, but the problem goes on. And the defense+ event shows:
xxx.tmp Access memory x:\xxx\xxx\c4.exe
xxx.tmp Scanned online and found safe
xxx.tmp sandbox partially limited

Since the temp file is likely always changing, CIS is continually going to see it as an unrecognized file. You’re probably going to want to give it the Installer or Updater predefined policy.

Go to Defense+ → Computer Security Policy → Defense+ Rules and click Add → Select → Browse.

Now navigate to the games folder and select a .tmp file. If you don’t see a .tmp file, then select any file and click Open. Now edit the path to read something like x:\xxx\xxx*.tmp, then click next to Use a Predefined Policy, then select Installer or Updater and click Apply.

Edit: This may be obvious, but it’s important that you definitely have the path pointed only at the .tmp files in your games folder. You don’t want to give all the .tmp files on your system the Installer or Updater policy.

Thanks for the response.
The xxx.tmp file is at \Documents and Settings\local configuration\temp and it is always the same. But I did your suggestion with this file at temp folder, and it don’t function also.
If I disable the sandbox option, this game should run, shouldn’t it? I did it so, but one don’t execute the game.

Last post moved here.

Please follow the Forum Policy at all times.

Thank you