Problem with right-clicking icons [Resolved]


Yesterday, I was unable to right-click any icons at all on my computer.
Not even my HDD. Computer jut froze and I had to open task manager, kill explorer.exe and retart it for my computer to respond. I’ve ran HijackThis, Ad-aware 2007, Spybot S&D, Avast Home Edition, but none of them find anything.
I think I know what the problem is, tho it shouldn’t be the problem.
Yesterday, I ran Eraser’s unused disk space thing, which fills your HDD and then remove everything.
I did this on D:, which isn’t my system HDD, but contains the pagefile. But the pagefile shouldn’t mess up anything, as it was in use by the system and couldn’t be accessed.

I’m running Windows XP Pro 32-bit, version 2002, all updates installed.
Programs that I run shouldn’t matter as they have been running fine for about half a year.
Any help is appreciated.


Did you only recently install eraser or some other software that adds anything to the right click context menu - sometimes this can cause problems such as you described.

If this is the case you could try uninstalling Eraser or whatever it was to see if it fixes the problem.


I’ve had it installed for some months, so that shouldn’t be the problem.
But I’ll try and disable it from the context menu and see if it helps.


EDIT: It didn’t help.

Make sure HKEY_CURRENT_USER/CONTROL PANEL/DESKTOP/MenuShowDelay is not set to 0.

Probably clutching at straws but worth a look.

Also, try opening System32 and look for verclsid. Rename it verclsid.old and see if that works.

Have you got DivX installed?


No, it’s set to ‘1’.

You mean ‘verclsid.exe’ I suppose.
But no, it didn’t work.
Seems like this error only occurs when I right-click a folder, zip-file or my HDD’s.


EDIT: I also restored all my registry backups from registry cleaners, but none of them solved the problem.

Maybe there is a problem with your shell extensions. Try this:

and read this article:


What about group policy editor or system restore/backup?

That article helped me.
Seems like removing EraseExt from HKCR\Folder\shellex\contextmenuhandlers and HKCR\Folder\shellexDragDropHandlers solved my problem.
Thank you very much, I’ll bookmark the page in case of future problems.
And once again, thank you very much for your help N.T.T.W .
And also 5 xp reward for Soya :smiley:
I’ll save your work and close the thread and mark it as [Resolved] :-[


Glad you fixed it Ragwing. Ill lock this topic now it is resolved. If you need to open it again let one of the Mods know.