Problem with program start for external application after Update to Ver. 12.1.0

I run COMODO Internet Security since many years with no problems.

I have following issue after update to Ver.

One of my vehicle monitoring programs runs well with up to version 11.
From ver. 12 if received after starting the error message
Application will be terminated.

I run the software on 2 Laptops (one WIN7; one Win10) both computers showed the same issue.

After messing arround with the vehicle software, and checking all clearances within Comodo – with no success - I de-installed comodo.

After de-installation of Comodo the vehicle software runs well again.

I installed version and the vehicle monitoring program worked fine.
I updated up to ver. 11 and the software worked still OK.

After the update to Ver 12 above error came again.

I approved in COMODO this program to run, there was nowthing in the container or blocked.

Now I run my WIN7 Laptop with Ver. and will not make an update.

Any ideas on this bug?

You should try the latest version and if you still face the issue, try adding the application to the exclusions of detect shellcode injections.

THX, I currently run on my WIN10 Laptop CIS Ver.
No actualisation of a new version available.

But I tried your Fix with above version and it worked OK
Thanks again for your support.
I try it now with my WIN7 Laptop as well