Problem with logs

Hello everybody,
I have big problem with comodo v3. When v3 was released I switched from v2.4 to it and everything works fine. After some time I noticed that v3 does not log anything. Neither firewall nor Defense+, there is absolutely nothing in log. So I tried to completly uninstall Comodo firewall and install it again and problem still preserve. And even more, Comodo does not even create its log database (“c:\Documents and Settings\All Users\Data aplikací\Comodo\Firewall Pro\cfplogdb.sdb” ). Now when I tried to look for log events there is 50% chance that Comodo aplication will hang-up completly. This happen to me on two machines. Any idea?

btw GUI is really slow as hell. To be honest I would much rather have normal windows looking fast GUI than some fancy but slow GUI.


I’ve had sort of the same problem with v. that didn’t exist in earlier versions. I’m showing no firewall events blocked but do have defense+ events logged. My update from an earlier version of 3.0 didn’t go well, so I uninstalled CPF and installed from scratch. And since then, nothing showing as being blocked whereas before there were always dozens of probes per session. I checked settings and logging was set to delete the log file if it was bigger than 0 MB. I changed that t 10 MB and rebooted. Also made sure that disable firewall and defense+ logging were not selected.

Any ideas?


The Firewall log question is one that comes up regularly.
By default the setting in…
“Firewall/Advanced/Firewall Behaviour Settings/Alert settings”
is set to low, if you set it to Medium, or a higher setting you should see the logs return.
However if you are behind a router like me, you never seem to see many, if any items in the log even if it’s set to Very High.
Like you I wondered if the Firewall was actually working at all, until I was told of the settings.

Hope this helps,


Thanks, I’ll try it.

Having my 2Wire Gateway modem fully stealthed and echo pings blocked I don’t get big logs or firewall event alerts.

To MikeG: No help for me. I have alert settings set to high, also I notice some time before that log db size is set to 0MB so I set it to 10MB and set directory for copy when it reach this size. Also I’m not behind any router I have publick IP thats means I have several external attempts for connection every second (in Summary tab is intrusion counter which keeps running, 5000+ intrusion right now and keep running, but not a single entry in log). Any other idea?


Try to set default settings for logging: log size 2 mb, action - delete and recreate new, disable logging (2 options) unchecked.

If problem is still there,

Comodo does not even create its log database ("c:\Documents and Settings\All Users\Data aplikací\Comodo\Firewall Pro\[b]cfplogdb.sdb[/b]" )
So, do you have this file on your HD? Anyway here is the [url=]link[/url] to mine, so if you on XP x32, move it to that folder, restart Comodo and see whether it makes any difference.

I just did a test. I took a known trusted program ( CCleaner ) and edited in Firewall rules to Block. Then I ran CCleaner and checked for updates. CCleaner could not connect and when I looked in my logs it was there. Logging working like it should.

2 Goodbrazer
Regarding existence of firewall log file I have two expirience. On both my machines there was log file but based on datum of last modification clearly not used. On one machine I completly uninstall comodo (that dele this file) new install of latest version did no create a new file (also when trying to look into the log GUI used to hang-up check this thread )
On second machine I didn’t uninstall/clear install comodo yet, so I tried your log file but without success. Comodo just did not touch it.

BTW Colleague of mine also have this logging problem so it already 3 machines with the same problem

Export your configuration, delete all global rules, add global rule block(not log)/ip/in/any/any/any at the first one. Add global rule block&log/ip/out/any/any/any as the second one. Launch web browser. Is anything there in the log (web browser blocked)?

Does internal log viewer work for you (button “more” on “view events” tab)?

Shut down all your actively-running applications to see whether log is working with same configuration ^ (2 global rules).