Problem with installation CIS 8

I am trying to update my 7th version.
I don’t want to install anything but firewall component - so only firewall was chosen in installer options. Actually all other marks were disabled (SecureDNS, sending statistics etc).
Anyway I cannot neither update nor install after full uninstall - error 1603. I am dealing with the 8th version "Premium Installer’- MD5 sum of file I have downloaded is a2ea26bb22947d7c23596dd18c09b579.
The logs of installation are attached.
I’ve tried full uninstallation scripts from this forum, several reboots - anyway the result was the same.
When I tried to install 7th version - there was absolutely no problem. So looks like 8th installer is faulty (as for Win 7 x64 at least).

[attachment deleted by admin]

Please try the following solutions:

Run > regsvr32 Atl.dll
Run > msiexec /unregister
Run > msiexec /regserver

Update the Microsoft Windows Installer

Thank you very much for your suggestion!
Before I will try to do all these stuff could you please advise why I need manually register some library and re-register or update Microsoft Installer for installation CIS 8 - and I don’t need to do it for installation CIS 7?

Anyway you can forget about your suggestion. Because it doesn’t work. Again: 99% and even shortcut appeared at my desktop - but then it disappears and I receive above mentioned error with 12 files named TBD3xxx.tmp in destination folder.

I want to say it once again: CIS 7 INSTALLS WITH NO PROBLEM! So please don’t try to find something at my system, try to find in installer of CIS 8.

The problem is that only a few experience your issue. As for example, I’m using your setup and I didn’t experience anything similar.

The problem is this issue exists at all for security software.

I will try to replicate your issue on a virtual machine.
Please provide a system summary. (run > msinfo32 > save)

I can post even two files because my friend expects the same issue at Win7 x32 system.
Possibly “a few” means either significantly or me and my friend are lucky twins :slight_smile:

[attachment deleted by admin]

Well. Another suggestion,

Did you try to manually search for registry etries that were left behind and remove these (after a normal uninstallation procedure)?
As for example, you could make use of this utility. Just tweak the settings a bit from “Configuration” to be suitable.

Yes. Actually I did it manually using regedit and “comodo” as a search string.

gjf, if you do not mind please do create a bug report with the required format. It should normally classify as a (very) high importance bug report.


No problem:;new#new