Problem with external drive and portable applications


A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: yes, i’m very sure what the problem is.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: just connect an external HD with portable applications, example: firefox, thunderbird, poppeeper, essentialpim, etc. and try to use them to connect to the internet. They just stay blocked even after in the previously day i’ve given access in the firewall.
  • If not obvious, what U expected to happen: In the previous version (5.12.256249.2599) after i connect the external HD with my portable applications, sometimes the firewall asks to give permission sometimes it just detected that previously it had permission and it didn’t asked just permits access. In the new version (6.1.276867.2813) nothing happens just block everything from my external HD. With the external HD connected if i close the firewall and the reopen it, it starts working as it should, permiting and asking again for my permission for the portable applications.
  • If a software compatibility problem have U tried the conflict FAQ?: not a software compatibility problem.
  • Any software except CIS/OS involved? If so - name, & exact version: no.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: The only solution i have found is everyday in the beginning of the day, after i connect my external HD i immediately close the firewall and reopen it. Then i star to open my portable applications from my external HD.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: Comodo firewall 6.1.276867.2813, Behavior Blocker disabled, Firewall with Custom Ruleset, everything else default.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Behavior Blocker disabled, Firewall with Custom Ruleset, everything else default.
  • Have U made any other changes to the default config? (egs here.): no
  • Have U updated (without uninstall) from a CIS 5?: i updated and and in the procces the version 5 was uninstalled and rebooted and automatically 6 was installed.
    [li]if so, have U tried a a clean reinstall - if not please do?: no, but i don’t think that is related to the problem… :frowning:
    [/li]- Have U imported a config from a previous version of CIS: no, all rules empty after the install
    [li]if so, have U tried a standard config - if not please do: no, i need the firewall to ask me for all communications, because of that is in the Custom Ruleset.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: win xp pro, sp3, 32bit
  • Other security/s’box software a) currently installed b) installed since OS: a= none b= none

Previous post (if this can help):
I just installed your new version of Comodo Firewall Free, and this last version is having a problem.
I have a external hard drive of 500GB that i use with my portable applications (Firefox, Thunderbird, Poppeeper, EssentialPIM, etc…), and all my docs and work in it.
With previous version of the firewall, some times it would detect my portable applications as a new one, and asked me for permission to connect the internet. That was a bit boring, but not very problematic.
But with this newer version i can’t connect the internet with my portable applications, and the firewall don’t even ask for permission, it just blocks everything from my external drive.
After various tests, i have found that if i close and reopen the Comodo firewall in the tray, everything starts to work immediately, because i had previously given access to those applications.
Do you know about this problem? Is it a bug, can you solve it?
Nuno Leite

Please edit your first post so that it follows the format provided in this topic. Also, be sure to include all required attachments.

Please let me know if you have any questions.


Thank you for putting your bug report in the standard format. That is very helpful.

However, could you please attach the diagnostics report and the Watch Activity process list to your first post? I need this in order to forward this to the devs. Also, a screenshot of your firewall rules would be very helpful.

Also, as this was not a clean install of V6, but an installation of V6 on top of V5 would you mind uninstalling and then reinstalling CIS by following the advice I give in this topic? The reason I ask this is that there have been issues between the rules which were created with V5 and V6. Thus, if you reinstall V6, without importing any rules, and the problem persists this is definitely a bug.

Thank you.

PM sent.

Okay, for the time being I will move this bug report into the Non Format Issue Reports section. As soon as you are able to attach the diagnostics report and the process list, and checked to see if reinstalling solves the problem, I can move it back. Once you have done this be sure to send me a PM to alert me to the changes you have made.

Thank you.

Sorry i dind’t had the time to do those tests.
But i’ve already seen that there is a new Firewall version 6.2.
I will test it and i will give you the news if that solves the problem.

Thank you.

Hopefully the problem is fixed, but if not please attach the necessary files so I can forward this to the devs.

Is this problem fixed with CIS version 6.2.282872.2847?

If so I will move this to Resolved. If it’s not please attach the requested files and I will forward this to the devs.

Yes, it seems to me that it is solved.
After connecting my external drive my external apps work immediately. Before, i had to close and reopen Comodo, now that’s not necessary.

Thank you for testing this.

I will move this to Resolved.