Problem with CPF and Avast Web Shield

Since the last CPF update, I get a lot of strange behavior in Firefox if I have Avast Web Shield enabled. For example, if I try to load my home page (, I get presented with a popup message that says I’m trying to download content of type application/octet-stream. I’m then asked if I want to download it or open it with some other application.

This problem only happens when both CPF and Web Shield are active. I can disable either product and the problem goes away. This behavior began after the most recent CPF update.

Any idea what is wrong? I’m becoming very tempted to dump CPF and go with a different firewall. I’d rather keep CPF and fix this problem.

Any thoughts?


I don’t have your problem, but there is a thread going on in the avast-forum about your problem:

Yes, I know about that thread. I started it. :slight_smile: I’ve run into others who are having this problem, as well, so I’m doing what I can to find a solution. So far, no one has any ideas about what the problem might be, but it only happens when both the new CPF and Web Shield are running. It did not happen with the last version of CPF.

Okey :slight_smile:

Stop on access protection in avast. Delete CPF rules for Avast webshield and then restart avast on access protetion. That fixed it on mine (creates new rules)


I’ve been running CPF with avast HE for a few days now. So, far I’ve not managed to replicate the problem. However, something did occur to me that might help… ensuring that both ashWebSv.exe & ashMaiSv.exe, in CPFs Application Monitor, have “Allow invisible connection attempts” & “Skip advanced security checks” both checked. Trying to make avast as transparent as is possible to CPF. Which, I guess, it should be. Despite, not being able to replicate the problem, I’m going to use this set-up with avast for awhile to see if makes any difference to me.

I just tried those settings and they do not help. :frowning: It was worth a shot, though!

OK, sorry about that. The question is… what’s the difference between our 2 systems? Since, I don’t have the problem, I suspect there is a third element/component involved here. If you agree we also need to find things that you and other users with the same problem have in common. What do you think?

Just one my question about activity page. Why when i am browsing with Firefox all activity in comodo shown as ashWebSv.exe and not Firefox? Skype or icq shows separately, but why firefox are masked behind avast web shield?

That’s how Web Shield works. It’s a local proxy through which all of your web traffic is scanned. So, you’re browser doesn’t directly access the web. It goes through Web Shield first.

But avast has p2p and instant messages shield, but skype and icq shows normal… With others firewalls like Zone alarm and Jetico shows normal that Firefox is connected.