Problem with colleting certificate on IE8


I have found some topics with this problem already, but none of them contained any solution. So I ask once again.

I just received my certificate from comodo, but everytime I click the link inside the mail, I only see this page:

You need to authorize the "Microsoft Certificate Enrollment Control" to install your new Certificate: Click here to reload this webpage, then... When you see a Security Warning popup, click Yes to install the "Microsoft Certificate Enrollment Control".

The problem is, I can click on “here” as often as I want to, nothing happens. I don’t receive any message popup where I could decide to accept the certificate.

I tried several changes in IE8, disabling every security feature, adding comodo urls to secure sites and so on.
Nothing works…

Any idea how to get this solved?

Thanks a lot!

I’ve the same problem on my Vista Home Premium box. It’s OK when I tried on XP OS in IE8.

The main problem that IE does not show me the message to allow Microsoft Certificate Enrollment.

Hi Downy,

We have confirmed this issue with IE 8 and Vista Home editions.
Can you give more information about your environment:

  1. OS and version
  2. Comodo SecureEmail (CSE) installed or not (and which version if yes)
    3)Which way have you ordered the certificate?

We are looking how to solve this issue now.

For now We recommend to order certificate via CSE Sign-Up Wizard and receive it with CSE - it should be automatically installed by CSE without navigation to any web-page.

I hope this post will help you in resolving your issue.

Regards, Eugene.


many thanks for the replies!

Here are some answers:

  1. I am using Windows Vista Ultimate 64 Bit here, all updates are installed.
  2. CSE is installed with version
  3. After CSE installation had finished I was asked to create a certificate and so I did.

I would like to try to order a certificate in the way you have mentioned with the CSE sign-up wizard, but unfortunately I am not able to register another certificate for my email address as there is of course already one.
Is there a way to solve this from your side? Maybe you can revoke my first certificate request which I can not install?

At this point, thank you very much for your assistance!

Exactly the problems for me (including the already existing email address when trying the CSE Sign-Up Wizard option. :-\

Hi haemoglobin,

You should first revoke your first certificate (that failed to install) and then request new one with Comodo SecureEmail Sign-Up Wizard.

Note: To revoke your certificate you should send e-mail to cse-support[at] from the same e-mail address as your certificate issued for and ask to revoke your certificate.

Regards, Eugene.