Problem with Atmel Studio & Comodo Internet Security

I am using Atmel Studio 6 to develop software for AVR micro-controllers. During the compiling phase, Studio creates a randomly named .BAT file in the windows/users/xxx/local/temp directory. This is caught by the behavior blocker and I get a message saying that the batch file “makexxxx-1.bat is an unrecognized file and has been sandboxed” where xxxx is a random number, different every time. As a result, the compiler fails. The only way I found to work around this is to disable the behavior blocker.

Any suggestion?


You need to give Atmel Studio executable the Windows System Application policy in Defense +. When running the default Internet Security configuration you need to enable Defense + for this to work.

With v5 the Installer/Updater policy would do the trick but that does not seem to be working with v6 for some reason. Can you try using Installer/Updater policy to see if that works or not (for the sake of testing)?


Can you explain how I should d this? I look at the advanced settings, but I cannot find anything that fits.


You can enable D+ HIPS under HIPS Behavior Settings.


I tried this (advanced settings → Defense±>HIPS
I enabled HIPS and tried both Windows System Application and Installer or Updater for Atmel Studio and it did not change anything. I even tried to apply the setting to make.exe (which is launched by AS when I compile), but everytime I compile, a dialog comes up and ask if I agree to let it perform its task. I checked the option to remember my answer, but it didn’t change anything. I guess because the make file created is different every time the compiler runs.

I’m going to continue to disable the behavior blocker for 60mn at a time when I’m working. It is more an inconvenience than anything else, but I wish there were a solution.

BTW: Atmel Studio is a free application, if anyone from Comodo is willing to try, it can be downloaded from this page: . In the meantime I will continue to experiment and I will let you know if I find anything.


There is one thing I forgot. Check the Defense + rules and see if there is a rule by the name “All applications”. If it is present then see if the rule for Atmel Studio executable is underneath the “All applications” rule. If it is drag the rule for Atmel Studio to a place above the “All applications” rule. That should do the trick.


I could not find a rule names “All applications”. I think the problem comes from the fact that Atmel Studio creates batch files to execute the compilation. These batch files have a different name every time and it does not help to check the do not ask again. Comodo stops those .bat files when they try to access a file. If I click on allow, the program will go on, but it means that I have to do this a few time during the process :frowning: .

At least it proves that Comodo does its job. Thanks for helping. I appreciate it


I made a screenshot of the HIPS Rules showing the All Applications rule. See attached image.

In my previous post I used Defense + Rules where I should have used HIPS Rules. Make sure the rule for Atmel is somewhere above the All Application rule.

Keep us posted.

Sorry, I was looking at the right screen, but did not scroll down far enough. Atmel Studio is way above the “all applications” rule set. No change…