Problem using Windows Live Messenger

Greetings all,

When I try to log in on Windows Live Messenger, i get the following error:

I’ve tried all solutions I’ve come across on Google, like changing MTU to 1400, set time correct(it’s set after an atomic clock, and it’s the most accurate clock in the world…), and I’m not using any proxy.
I’m using Windows Live Messenger 8.5.1235.0517 .
I’ve tried to disable CPF, but still won’t work.
I’m using a router, a D-Link DI-524.
When I click troubleshoot I get this:

What does ‘Your gateway appears to be offline’ means?
Any help is appreciated.


Have you tried resetting your Router?

Also, is it possible a corrupt winsock could cause this?

I think it most likley something to do with your Router, if resetting does not work it may be worth looking at the settings if you can.


Do you mean reset to factory settings?

I’ll send you my settings for the router if you want.


EDIT: It’s not related to the router, I put the cable into my PC instead of my router. Still got ‘Gateway dead’ error.

Come on - give me at least 30 EXP this time (assuming the above file is not malware-infected ;D).

Nothing of it worked, it still says ‘Your gateway appears to be offline’.


There goes your 30 points, Soya!

Yeah. Thanks for reminding me.

How about reinstalling Windows Live Messenger? (I don’t want to have to resort to “how about installing some other client” solution).

I’ve removed WLM and all its registry keys, then re-installed it, but still won’t allow me to sign in.