Problem starting CIS

One day I got a problem starting CIS after and update and a reboot. It just says “COMODO Security Agent could not be started. Would you like to run the diagnostics tool to fix this error?”

I runed the diagnostics tool but it didn’t find any problems. So I completely uninstalled it with the tool provided and then installed it again.

After a week or so the application stopped to update the virus definitions. I tried to press update but nothing happened. So I close the application at the tray icon and then started it again. And there it is again, same error message as above.

So what can I do to finally solve this?
I’m on Windows 8 and here, TikTokDownloader - Download Video tiktok Without Watermark - SnapTik - en, is the diagnostics report

I’d clean my Registry: Raxco PerfectRegistry, ERUNT, CCleaner IObit Advanced System Care, do a chkdsk C: /f /x on every disk unit, remove any unnecessary software, ‘msconfig’ to eliminate unwanted start up software. Check event viewer (eventvwr.msc on command line (Windows+R)), check for hardware errors, then software ones, drivers not loading, next you could choose the option to empty all events: Application, Security and System and the reboot your PC and see what errors you get and take it from there.

I am using cispro and after doing the latest program update I have the same problem, comodo will not start when the computer is rebooted. I have uninstalled and reinstalled it several times now and it is now starting after the reboot when I prevent it from installing the latest update.

However, I am now unable to activate my license key as the space is filled with already with dash lines and I can`t remove them or enter my license key. I am at this moment doing a full scan of my computer with the latest virus database installed, and hope that this will fix the problem after a reboot when the scan is finished.

I will post again if I am still unable to enter my license key after my full computer scan is finished. As I did a full scan with the previous version of the updated software I doubt it will make a difference… any ideas on how to activate my copy of CIS PRO

If my suggestion above doesn’t work, I’d consider making a new Win 8 installation from scratch and being careful Win 8 compatibility and other software you install, I had a boot sector virus that wasn’t found by latest Comodo Clean Endpoint, Avast! IObit Antimalware (didn’t try Malwarebytes Anti-Malware), that boot virus didn’t let me even boot Win7 64-bit after a clean install, I had to delete partition and reset the master boot record of other partitions with a utility called ‘bootsect.exe’, it should be in the Win 7/8 installation DVD-ROM.

h:\SOURCES\W7T64\boot>bootsect /help

bootsect {/help|/nt60|/nt52} {SYS|ALL|:} [/force] [/mbr]

Boot sector restoration tool

Bootsect.exe updates the master boot code for hard disk partitions in order to
switch between BOOTMGR and NTLDR. You can use this tool to restore the boot
sector on your computer.

so to reset a partition: bootsect nt60 C: /mbr /force
‘ALL’ is only for partitions that actually boot an OS, you must do this on all disk units to clean the boot sectors and my problem was fixed, even though I don’t know if the problem was I formated some disk units with WinPE, XP version but I don’t think so because the file corruption, which caused all my problems, was at random files, generally when copied or downloaded, at random positions within the file always writing 4 bytes, can’t recall the hex numbers, so weird random errors might me this virus and it came from some ‘keygen’ I downloaded and disabled all security and forgot to sandbox it. Once I reset all the boot sectors on all units and rebooted everything went back to normal.

My computer freezed, mouse and keyboard too, and rebooted without a BSOD, also gave me BSOD of MEMORY_MANAGEMENT, 1A (complete Wn 7 hang), 50, 3B; a real nightmare.

It’s probably not necessary to reinstall Windows 8. That would be a last resort which I see no reason to jump to right now.

For starters, please see this topic and see if reinstalling CIS by following those methods solves your problem. If not then we’ll try some other approaches, but I strongly doubt that reinstalling Windows will be necessary.

Thank you.

As stated in my first post I tried that already.

I understand that you’re just trying to help Saul, but checking for hardware errors or reinstalling Windows is a bit far fetched…

Did you follow all advice, including that in Section B? I’m just asking because from your post it wasn’t obvious whether you had used more than just the removal tool (which admittedly is able to solve most problems). However, some problems cannot be fixed with that, and thus the methods in section B are needed.


No, because it says if you cannot install CIS. I can install it but after a while it fails.

I apologize. The wording in my topic was misleading. I have now corrected it.

Please follow the advice in Section B and see if that is helpful.

try to re install cis and do the fresh install and also look that you don’t have any other security suite enable on your pc. if any other antivirus is there on your pc then uninstall that antivirus with that specific antivirus uninstaller and then try to install cis.

Thank-you Chiron for the very informative topic, I followed your instructions but Comodo was still causing me a problem when I rebooted my computer it still wouldn’t load automatically but I was able to start it by going to my start menu and logging in to the Comodo Task Manager directly and it would start then with all parts of Comodo running.

Last night I ran Perfect Disk Defragmenter and when it tried to reboot my computer it caused a BSOD. Once that happened, it defragged my boot files and Comodo loaded every time after that when I rebooted and I was able to install my license key. So at this point the problem appears to be fixed. Time will tell if it`s permanently fixed or not.

BTW I am using Windows 7 … I don`t think I mentioned that in my other post.

I did that in the first post

I did section B also and the problem is the same.
After installation, then first update of CIS and after reboot the same error message is back.

Please list any other security applications you have installed. Also list maintenance programs.


Hm, non security apps.

I use Download App, SlimDrivers and Secunia PSI for “maintenance”. Which I have done a long time side by side with Comodo, until this update.

With a problem like this I would look for a compatibility issue with drivers. In this case I am wondering if temporarily uninstalling SlimDrivers makes a difference. Could you try?

That actually worked.

So what can we do to solve this compatibility issue?

The only thing that can be done is to file a bug report. Best is probably to file with both Comodo and the makers of SlimDrivers.

As for filing a bug report here: you can file a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Reporting of bugs is strictly moderated to make sure Comodo gets clear bug reports. So, please make sure you closely follow protocol. That way your report will certainly be seen by Comodo staff.

I’m using windows 7 not 8 like the TC and I have no problems with Slimdrivers and Comodo on my PC. The strange thing is Slimdrivers just lets you know if your drivers are up to date and downloads the latest ones for you. I’m surprised it would cause this problem.

Even though Windows 7 and 8 are close cousins with their driver model they are still not totally the same. Also differences in hardware or installed software define bugs in one system where hundred others go unscathed.

Understanding bugs with programs using drivers is always more then a bit of a dark art for the non initiated… :wink:

I know how to test and troubleshoot and when it reproduces it is up to the skilled people to get to the bottom of it.

Seems like a reinstall of SlimDrivers solved it for now, lets see how this develops.