Problem sending Yahoo mail

This one has got me stumped and I have been trying to fix it for a couple of days with no success.

Using Pocomail for my email I have 5 accounts one of which is a Yahoo account. I have full access to pop and smtp with this account so that is not the issue.

If I send off my mail all of my other accounts are sent but for Yahoo I get this following error.

Logging into SMTP server... Could not connect to SMTP server Cannot connect to SMTP server (, connect error 10060

So first thing I did was close down Pocomail, remove Pocomail from both Firewall and Defence+

Ran Pocomail once again letting Firewall and Defence+ do their thing sent the email and off it went just as it should do. Fixed or so I thought.

Back at my PC later in the day once again went to send email and again the same error ???

This time I decided to shut down Firewall just for quickness, tried to resend my mail and off it went just as it should.

So I ran CFP again then removed all the rules for Pocomail once again.

I ran Pocomail let CFP do it’s thing but this time I edited the Application rules for Pocomail changed it from Trusted Application to Email client.

Crossed fingers sent my email and off it went. I was hopeful that this would be the end of it, but no.

On my computer this morning sent off some mail and once again this error when sending Yahoo email. Removed all references of Pocomail from from Firewall and Defence+, ran Pocomail again CFP did it’s thing and off my mail went. That will be that until the next time I try to send my mail.

I am now officially stumped as to what is causing this. Any help greatly appreciated.

Hi Luxor

This may be a long shot but I think Yahoo SMTP uses port 587. Check your Firewall/ portsets and make sure you have 587 under pop3/smtp.


Thanks for the input John

But as you say a longshot and 587 is already there under pop/smtp.

Last night once again I could not send yahoo mail but didn’t have time to play about with it.
This morning it sent off fine, now I’m even more confused.

Are there any related entries under view firewall/defense+ events?
Can it be by any chance that it is server’s or mail client (not CF’s) problem as in one case it works with CF turned on, but in other case it doesn’t work with CF turned on and with same CF’s settings?

There were no related entries under events, first place I looked to be honest.

Doubt that it’s a Pocomail problem, been using it for years and never had this issue before.

As for the server well who knows the answer to that one. As I say mail from my other accounts are getting sent so it would make you think that, I know I did. But as I can send email no problem when I don’t go through CFP or when CFP first picks it up I have my doubts. It just seems to be on subsequent uses that my email won’t send.

This is still happening to me.
Convinced now that it is a problem with CFP because if it’s taken out of the chain my mail goes no problem.
Apart from having to remove CFP from my system I would be greateful if anyone can come up with a solution.

Go to miscellaneous/settings/logging tab and verify there are default values (2 mb, delete and recreate, “disable…” options are not checked).
Now it should show something related in the log.

Do you mean complete uninstall or disabling firewall only, or disabling both firewall and defense+ , or…?

Everything there is as you have stated but still nothing in the log.

Do you mean complete uninstall or disabling firewall only, or disabling both firewall and defense+ , or...?

Exit from the firewall mail sends.
Remove pocomail from firewall and defence+ mail sends the first time but not subsequent unless I remove Pocomail again or exit the firewall.

One more thing to try: uncheck (or leave unchecked) 6 options under firewall/advanced/attack detection settings.

Not sure what you mean by check/uncheck there goodbrazer
This is the settings I have there, I take it this is what you mean.

Or did you mean the options under the miscellaneous tab ?

I think Goodbrazer referred to the settings under miscellaneous.
Is it possible that this is a sort of “time-out” issue?
Maybe your email client or the server is too strict regarding this. It is possible that cfp’s inspection causes a slight delay. As far as I know 10060 is a Connection Time-out error that usually appears when the client does not receive a response from the server for a specific command.

As you have 2 options unchecked on screenshot then yes go to miscellaneous tab and uncheck all options (4 items).

Ok the only one there checked was Block Fragmented IP datagrams

It’s now unchecked and we will see how things go.
Will have to wait until later as I have things to do though.


After unchecking Block Fragmented IP datagrams I can now seem to send my Yahoo mail.

There is a bit of a stall, almost like Pocomail is not responding but it does go, just not immediately like my other mail accounts. Note that I don’t get this behaviour if CFP is exited first though. If I do that then it goes immediately every time.

I will see how it performs over the coming week.

Update. I can now report that after 4 days this still happens more often that not.

I hoped that the new version I installed today would maybe fix it, but my first attempt to send yahoo mail failed with the usual error. :frowning:

Are you talking about Yahoo Web Based email? Works fine on my end.

No, as stated at the start SMTP.

Have you tried making your e-mail client a “Trusted Application” in D+,it might just allow it through that bit quicker?
Could be worth a shot.


I’m sure that I have tried that already riggers.
Think I have tried everything possible to change this behaviour and nothing is making a difference.

Finding it quite annoying now to be honest.