Problem installing CIS

Hey guys - Just formatted from Vista - I’m back to windows xp sp3 and I have some problems.
I downloaded onto a clean machine the latest version of CIS free, Double clicked on the setup file and got pompted to select the language - I then clicked next, seconds later started to install all the components as normal. How ever - then it asked for a reboot. There WAS NOT a prompt to select which components to install, Hopsurf,Dns, anything. Shortly after I get a message saying CIS has encountered a problem.
After reboot I tried to add\remove components, Adding the AV was not successful. I uninstalled CIS completely, removed reg entries etc.

Windows Xp Sp3
Running Sandboxie realtime
attached is dumpfile.

Any other info provided on request…

[attachment deleted by admin]

I’d like to add that Comodo Firewall and D+ function as they should, 340/340 with CLT.



I’ve seen similar things happen before; appears related to corrupted download. When I had the issue, I uninstall/reinstall from same installer file, and had same or similar problem recur.

It wasn’t until I got a new download entirely, and started over, that the problem was resolved.
I do believe they problem hash values for the downloads on their website; you might run a hash on your end and match them up to make sure you’ve got a good download.


I did try redownloading a copy from filehippo previously before you asking, However it was not a success and the same problem occurred. I will get around to checking the hash values tomorrow when I have the time and post back.

The Copy of CIS I have matches the same hash as Comodo website reports. ???

Weird. Here’s my suggestion, even though I hate to sound like a help-desk… :wink:

Re-download the installer from Comodo’s website, fresh. Make sure you have nothing else running at the time.

Use Revo Uninstaller to uninstall previous failed install of CIS. Get aggressive with it if you want.

Re-install CIS, making sure you do so as Admin. You probably are already, on XP, but just making sure…

Also, are you using CIS as a suite (with AV) or just firewall? Any other security software installed first (especially w/real-time protection)? If so, be sure to completely disable it (or uninstall) prior to installing CIS.

I know you know what you’re doing; just going back over the basic stuff just in case… sometimes we miss something we didn’t think about.


Hey LM, I went re-over everything. It just doesn’t work =\

I have no choice during the installation to choose which components to install… ??? I just select my language, Click next. window comes up saying “oops!.. looks like we’ve found a bug” or something simmiliar… Then it asks me to reboot.

Removed superfluous comment.

I mentioned at start that Originally I just formatted xp, I installed sandboxie and then CIS. I don’t think it has anything to do with previous entries.

Dang, Kyle, it doesn’t make any sense. I don’t see how sandboxie would interfere with it. If you have a clean XP install…

Hmm, here’s a thought. Did you update XP before trying to install CIS? I’m wondering if there are dependencies you need to establish prior to CIS. Windows FW should provide protection for just getting updated.

If you haven’t, might try that, and also uninstall sandboxie just in case.

If still no joy, you might want to file an official ticket w/support to get some behind-the-scenes help and greater coverage for this thread. If you file that ticket (you’ll need a separate login for support), provide them a link to this thread.



I’ll point some other Mods this way to see if anyone has other ideas.

Ok thanks. The widnows XP cd is sp2, I updated to sp3and then attempted to install CIS.
I’ll keep playing around, Hopefully I’ll find something and don’t stuff anything else up ;D

Wow, I re-went through the registry and I found an entry for comodo’s installer. Just a wild try - I deleted this, Re downloaded CIS and installed in safe mode…and…

It worked ;D ???
Coincidence? or maybe it was an actual problem…
The dump file from the problem is still attached to my OP if comodo needs to analyze.

Good, I’m glad that worked! Sounds like when “whatever” went wrong the first time around, the installer entry in the registry was continuing to keep you messed up.

Surely Comodo would want the dump file, but they certainly need to know context as well…


PS: I dropped the devs a note to steer them over here about your dump file.

Thanks for the help LM

I think sandBoxie might have interfered.
Do a clean install without it

Negative, I alot of comodo users also use sbie, I also managed to install comodo with sbie installed.