Problem downlading files with Firefox

Hey guys! I have Comodo Firewall and Firefox 36.0.1 and starting from 2-3 months ago while the Firewall is active it’s gives me an error while trying to download something in internet or simply doesn’t download it at all… if i disable the Firewall everything is ok :frowning:

C:\Users\Bolz87\AppData\Local\Temp\TrSlzaPh.exe.part can’t be saved because it’s impossible to read the origin file.
Try again later or contact the system administrator.

Hello :slight_smile:

The following might help solve your issue :

[ol]- Right click on the Comodo icon in your System Tray.

  • Check whether “Advanced View” is checked or not.
  • If so or after you’ve checked it, right click on the Comodo Tray Icon > Firewall > Settings
  • On the left pane > Application Rules. Check if you find Firefox in the list.
  • If you don’t right click anywhere on the list > Add > Browse > Files. Locate your Firefox executable.
  • Check “Use a Ruleset” > Web Browser > OK > OK[/ol]

It doesn’t work :8 i think it’s a bug inside the program, because 2-3 months ago everything worked fine

Hehe, let’s find out what’s going wong :wink:

Check your Comodo FW logs :

1 - Double click on the Comodo Tray Icon
2 - Click on the number next to “Network Intrusions”

Has Firefox been blocked ?

You can also set Firefox as an “Allowed Application” within Comodo HIPS
To do so you can follow the same procedure described in the first reply
but choose HIPS instead of FW

Absolutely not :slight_smile: and it’s also allowed in HIPS as “trusted application”

Maybe try to set Comodo FW so that it can show Pop-up Alerts
and set Alert Frequency Level to Very High.

Then set the FW to Custom Ruleset.

Try to download a file with Firefox and see if u get pop-up alerts.

Nope, no pop-up alerts :frowning:

Remove Firefox from the FW applications rules.
Make sure that Comodo FW can display pop-up alerts.
Set it to Custom Ruleset.
Run Firefox and when you get a FW pop-up alert regarding Firefox
give it Browser rights.

Ok reinstalled Comodo solved the problems, thanks for the help :slight_smile:

Ok :slight_smile: