Problem booting windows XP after running boot time chkdsk/f [Resolved]

I’ve just installed CPF today and all seemed to be working fine, even after rebooting. I then scheduled a boot time chkdsk (which I do every week or so) and rebooted. As windows started up the loading screen just froze. It didn’t even get as far as the chkdsk. I had to power off and back on.

On the next reboot I got the “windows did not shut down properly” message and even starting with “last known good configuration” got the same problem. I tried rebooting in safe mode - that spontaneously rebooted on the first attempt but I had success on the second attempt. Using msconfig to disable all non-microsoft services and startup options from safe mode didn’t help. The only way I could get a normal boot back again was to uninstall the firewall using your suggested command line option (fwconfig -uninstall) and also uninstall NOD32 antivirus whilst in safe mode.

After that I reinstalled CPF, then did a proper uninstall from Add/Remove programs and reinstalled NOD32 and enabled the standard windows firewall.

Is there an incompatibility between NOD32 and CPF?

Interestingly I had a similar boot problem with the latest version of zone alarm security suite 6.5 and running chkdsk(also reported by many others in their forums) , after previously having no problems with 6.1. This was one reason I moved away from zone alarm!!

Windows XP SP2
NOD32 2.5 anti virus
PGP Desktop 9.06 with WDE

No there is no incombatibility with nod32.

Maybe some application on the “Prefetch” folder under windows is corrupted. Delete the prefetch folder c:\windows\prefetch and reboot. Windows will automatically regenarate the folder and the applications in it.

(After rebooting type the following command under “start” → “run”

Rundll32.exe advapi32.dll,ProcessIdleTasks

and press “enter”. This will force windows to optimize again the prefecthed programs. Windows do it automatically evere 3 days) :wink:

I don’t think this is the cause - I ran ccleaner after installation - this clears out the prefetch cache. The problem occured only after triggering a boot time autochk using chkdsk/f. What changes could this be making to the system to prevent bootup ? The lockup occurs during the animated “windows is starting up” screen.

Do you have enabled the option “secure the host while booting”? If yes then there is the problem.

Within CPF’s configuration, there is an option to “Secure host while booting”. Can you double check that this is turned off? I don’t know that this is the root cause, but it will eliminate one possibility.

Hope this helps,
Ewen :slight_smile:

Would the “secure host while booting” option enabled or disabled by default? - I wouldn’t have purposely enabled this…

I don’t have CPF installed at the moment in order to avoid hosing my system, so I can’t check !! - I was going to wait for the next bugfix release which apparently will fix the issues reported in the “CPF hangs PC Upon Startup” thread (ie 100% CPU usage on initial network usage.) I feel that might be what I am seeing here? Then I’ll give it another shot :slight_smile:

Yes. If you used the advanced (custom) installation CPF gives you the option to enable it. Maybe you have done that by mistake

Well I’ve just tried again with version, the secure host option wasn’t checked, and it all works fine now.