Proactive setting causes errors/breaks apps but not Internet/Firewall

Fresh Win7 x64, Comodo Firewall

When I set to Proactive I get errors in some apps.
When I set to Internet or Firewall no errors.

What settings can I play with to fix this in Proactive?

When you switch to proactive configuration, under HIPS settings enhanced protected mode is turned on. This makes CIS operate as a hypervisor using appropriate extension available from CPU, in your case VT-x.

Thanks disabled the Enhanced Protection Mode which fixed this issue.

Is this a bug? Never had this problem from previous CFW 8. Does disabling this lower my protection enough that it’d be better going back to CFW 8?

I think it is a bug, you could try the newest beta to see if it still happens.

Restored windows from a backup (before installing CFW). Newest beta has same errors.

With Enhanced protection mode enabled I found:

-Can’t run Memu android emulator, starting Memu it gives a error message saying something like enable Virtualization for better performance and BSOD.

-Interestingly installing VMware Workstation I no longer get errors from CPUZ, Core Temp and Memu. All working fine. If I uninstall VMware Workstation, errors return.

Same errors from laptop. Haven’t tried installing VMware Workstation, but I assume it’ll work like on PC:

Interesting findings. I and a few other members had no issue with CPU-Z, CoreTemp, and HWmonitor when enhanced protection mode enabled on the latest beta. You should wait until the next stable version is released to see if it is fixed for you. I suggest for now to leave enhanced protection mode disabled if you regularly use cpu monitoring utilities.

Another test find; installed Windows 10 Pro, I don’t get any errors.

Back to Win7. Instead of disabling Enchanced protection, I’m going to leave it on with VMware installed since I do use it and seems to fix the errors. When next stable Comodo is released I’ll try again uninstalling VMware. VMware maybe why I didn’t have any errors from CFW v8.2 on older OS Win7 install.

Tried CFW v6, v7, v8. Errors start from v8, v10.

Is the hardware virtualization for whole CFW software? Or just a component like Sandbox? I may want to try some testing to see if it’s actually working for my situation.

As a whole but mostly for HIPS which is why the option is located under HIPS settings.

This is actually interesting. I usually set to proactive… and since end of august, comodo now corrupts every single driver and app and program. I have to system restore and then it removes comodo but reinstalls thousands and thousands drivers and files back (if you click on “see affected programs and drivers”) seems odd to me

Definitely know what you mean about corruptions. I think this is from older versions but like changing all file time/date stamps by adding alternate data streams to files which causes more problems for syncing and some other stuff I forget. Even posted a step by step guide here 4 years ago on how to properly uninstall Comodo Firewall without getting errors if you want to reinstall or update to new versions (btw which still applies to current versions I tested):

This particular issue/bug? this isn’t going to be resolved in next version since I already tested latest beta and this problem started from v8 around 2015?

I think it’s now time to start looking for Comodo Firewall replacement. Sigh so many PC’s I have to fix, my own, family, friends.