Privdog resets itself after CCleaner check-up

this settings (attached) works fine for the websites but when I clean up with CCleaner this settings turns default. :-\

this problem does not happen in my Iron browser. it happens only Cyberfox that firefox based.

I am using PD

*this video which shows problem : - YouTube

[attachment deleted by admin]

that’s right. can only hope the next version. :cry:

are you sure this isnt a problem with ccleaner. it sounds like ccleaner clears privdogs cache so all the settings get cleared.

thank you for your feedback :-TU
I have created a ticket for our dev.

Hi wasgij6,
thanks for your support :slight_smile:

if PrivDog Cache cleaned by ccleaner?, Why it did not happen for Chrome ?

and CCleaner has support for PrivDog ?

Thanks Nadya :slight_smile:

Hi NPoberezhnaya,

This is inform to you, this issue also happens in Comodo IceDragon 22.

Kind Regards.

thanks a lot (CLY)

It certainly does reset back to defaults every time I run CCleaner, sadly I clean regularly so have to keep changing the settings, hope that the devs can investigate and fix :slight_smile:

After running some tests I have found adding the ‘’ cookie to the ‘Cookies to keep’ list in CCleaner stops Privdog losing its settings for me, can anyone confirm this works for them as well ?

Hi AimeeLW,
I can confirm your findings, the cookie needs to be saved for the setting ‘Ads-Block All Ad Networks’ to stick in Firefox based browsers (IceDragon).
It appears that the cookie does not need to be saved for the other settings to stick (Trackers, 3rd Party Widgets and Statistics).

Thank you captainsticks for confirming this, hopefully at some point they can find a different way to store this setting, a cookie doesn’t seem appropriate for storing a setting since they are volatile in nature! I’m sure this is just some oversight and they will fix at some point, but at least for now we can exclude this cookie and have a temporary fix ;D

I confirm, true
but when I add “” to “cookies to keep”, only “Block All Ads Network” setting is not changes with this change. 3th Party cookie blocking is never change although I add “” to delete cookies or adding to “Cookie to keep” :slight_smile:

whatever it must be fixed ;D

This problem still happened in new version of PrivDog :-TD >:(

Sorry for any inconvenience (CNY) We added the ticket. Our devs will fix this issue as soon as possible.

Thanks Nadya for your interest :slight_smile: I lost my settings again…

New version released but it was not fix 88)

I am waiting then
Best Regards :slight_smile:

This issue still happens in the new version of PD v1.8.018 :-TD

@Nadya you said it will be fixed but now not fixed…

Bug is clear, solution is in your hands… but you still does not fix this…
What users can do more for you ?

I am leaving the PD…We will meet again maybe in version 15.xx.xx

Keep up the good work, you can lock the topic.

Best Regards

Hi yigido!

this bug is fixed in v1.9.0.1.
thank you for your waiting :slight_smile:

Hi Nadya,

Thanks for advance :-TU


The Bug is fixed. You can close the topic.
Thanks :-TU