Privdog, Firefox, and Google Calendar

Hi all,

Apologies if this has been answered, but I’ve read around and can’t find a solution yet. I’m running PD and Firefox 31.0, and my Google Calendar is frozen. Nothing shows up, and I can’t edit/create any events. I’ve tried adding exceptions to PD (*, and it hasn’t worked. The only thing that works is disabling PD entirely in Firefox addons.

The relevant threads I’ve read claim this issue was resolved in a previous version (1.9 or something), but I’m still experiencing this issue.

Thanks for any information.

Hi and welcome vReaction,
I Suspect ‘Google Calendar’ requires 3rd party cookies.
Please try disabling ‘3rd party cookie blocking’ found under PrivDog’s preferences.

Kind regards.

Thank you for the reply and the welcome.

I disabled 3rd party cookie blocking as you stated, but unfortunately nothing changed. I also played around with enabling/disabling the other Privdog preferences with no success.


Hi vReaction,
Sorry that didn’t help.
One other thing you could try is adding ‘’ to PrivDog’s exception’s list.

Kind regards.


No worries. I can of course quickly disable the Privdog whenever I want to use Google Calendar and then enable it when I’m done. Just thought I should let someone know there could be an issue.

I’ve tried adding several exceptions, none of which have worked so far.


Thank you for reporting this issue, I will bring it to the Developers attention.
Edit: I have asked Staff to take a look at this topic/issue.

Thanks and kind regards.

Edit2: Just to assist the Developers, do you have any other 3rd party blocking extensions that could be conflicting with PrivDog?
Thanks for your time.

My other Firefox extensions include Adblock Plus 2.6.4, Adblock Edge 2.1.4, Adblock Plus Popup addon 0.9.2, Bluehell Firewall 2.3.0, and Flashblock 1.5.17

Google Calendar works with all of these enabled. Additionally, I had Privdog before all of these extensions were installed, and the issue was still present.


Hi vReaction!
Yes, we fixed this issue but firefox was updated to v.31 and we have the issue again :frowning:
I will create the ticket for our devs and hope they will fix as soon as possible.
Thank you a lot the feedback :-TU