PrivDog is now released.


Hello All,

PrivDog is now available for download.

Here’s the direct link to the setup:

This version has one minor fix related to a uncommon upgrade scenario.



Check Windows Management Instrumentation (WMIPRVSE.EXE) for excessive CPU with Task Manager.

If observed, try restarting that Service in Computer Management Service (right click on the Service and select Restart). The restart appears to reset the high use.

Using MSCONFIG to disable the “Privacy Content Firewall” service (Privdog Firewall proxy I assume) also appears to stop the problem. I also disabled the Startup task for that test, but suspect the Service as cause.

So far, I’ve observed this problem in Vista and XP (still checking the later). Both those systems only recently got the upgrade to Privdog V3 and are both running the most current release. Neither system would automatically Sleep, which is what got my attention. The Vista system also got all the MS Tuesday updates this week, and that had me looking there first for cause.

The Vista system was using from 25 to 60% CPU before, and is now back to 5 to 7% CPU after disable of Privdog service.

One more observation: I don’t see a Dependency on WMI by the PCF Service, only RPC.

Yes~ This issue need improvement.

I did some follow-up tests today.

It appears the PCF/PrivDog service does a Dynamic load of WMI at start, which is odd. I tried some Dependency tests (Registry setting), but that didn’t resolve the high CPU problem. Only a restart of WMI after the initial load of PCF seems to clear whatever PCF does during start that initiates the problem with WMI. Stopping PCF and WMI and subsequently starting WCF seems to trigger dynamic start of WMI (and I don’t think that is normal behavior of well behaved services).

Normally, I’d expect a Dependency for WMI to exist in PCF Service entry in registry (doesn’t), if that service is needed during start.

The XP system drops from roughly 20-22% to about 5% after the restart on WMI, so impact of this bug isn’t minor.

I don’t know if there any secondary effects of the bug on other calls to WMI, but I can say that system Startup is significantly delayed on the old Vista system as it has alot of services for that business system and this conflict has a ripple effect on Start delays.

After reading some other threads, I see this problem was spotted on .96 release.

It had gotten fixed during beta testing but got reintroduced with On my system is the one version that does not upset WMI service.

OK, so it’s a code regression issue. Well, that suggests they know and can fix it pretty quick. I was thinking about a scheduled restart on WMI after system start as a work-around, but that probably isn’t needed if they can quick-roll an update on Monday. Otherwise, I do have a customer base that’s in trouble. If they knew about this bug-regression in .96, then why in the hell didn’t they fix it in .97?

I have a secondary problem with the MITM method on HTTPS certificates that I hope can resolve with exceptions or an off-switch (with off default). However, it has triggered alarms on some customers banking software add-on, so I may need to opt-out on the proxy product piece anyway. When method simulates known malware method, it can have problems. I would suggest a switch in the product to opt-in/out on HTTPS. I don’t know if placing the site in exceptions would pass-thru the certificate. More testing…

I’m guessing this is a FP.

And this too:

cannot download. I get a 403 when clicking on the link.

Confirmed. I will send a pm to Shane to let Comodo know.

Hi Eric,
The download issue appears to be fixed now.

Kind regards.

Nope, it’s not working.

Is the download still working? It’s nto working here. In that case it may be a problem with the load balancing as all three are on different continents.

Yes it is still downloading with no issues here.

Still bugged in Europe. That pretty much confirms a load balancing issue.

Not working for me either

Thanks for reporting. In Europe and America the download does not seem to work where Australia (usually teamed up with Asia) it does. I hope it gets picked up soon.

Is there any news on the download issue, I can’t download latest PrivDog version as I get the 403 error page every time I try, thanks :slight_smile:

Error message is this: “You don’t have permission to access /downloads/661/PrivDogSetup_3.0.97.0.exe on this server.”

I sent another pm to Shane.

Is there any news on this server issue, still the link has error and can’t download, tried from different computers, OS’s and a different house/ISP with the same result :frowning: