PrivDog Released

PrivDog is now released.

For existing users your browsers will automatically update on the browsers internal update schedule. You can manually update in both FF and Chrome if you choose from the browser’s ad on/settings panels.

The new setup program will be available at The setup is currently propagating to Cnet and may take up to 72 hours to appear. Here’s the direct link to the setup:

The setup has gone through virus total and is verified clearn from all malware and viruses: Here’s the link:

New Increased threat coverage

Fixed defect where: Plugin icon background should be transparent IE
Fixed defect where: Firefox plugin remains after uninstall Setup
Fixed defect where: Settings are not saved on preferences page IE
Fixed defect where: “0 blocked” instead of “0 detected” in pop-up for Ad Networks IE
Fixed defect where: Plugin icon background should be transparent IE
Fixed defect where: Setup doesn’t start in reinstallation mode, when PrivDog was removed from one browser Setup

Congratulations with the new release. Good to see a steady stream of releases.

I downloaded the installer to update Dragon as currently there is a problem with the updates of addons in Dragon. I updated PD in FF and CID from within the programs. When I ran the installer it said a newer version of PD is already installed and then it ends.

The version information in the properties of the PD installer states it is version with release date November 26. I am on Windows 8 x86.

Waiting for new version of Dragon…

Thank you for the update, PrivDog is being well fed. :slight_smile:

Nice doggy!

Installer does not work

I previously un-installed version from Dragon in preparation for trying the installer.

Unfortunately the installer would not install on Windows 7 x32

After running the installer - Against my better judgement because even Dragon complains that the downloaded PrivdogSetup being possible malicious - There is a Privdogsetup process listed in Task Manager, but the installer seems to be stuck doing nothing ( there is no installer dialogue visible on windows

Downloaded your latest installer ( which again I was warned “This file appears Malicious” )

Ran the exe and again nothing happens.

Open up Task Manager and there is a process for the installer … Which is seemingly doing nothing.

All I can do is end the process.

A few more details which may be relevant to the problem :

I do not use IE, but I believe Windows Updates have recently updated that to version 11 - So I guess there is potential for the installer choking on that

I have Dragon version 30 installed : As previously mentioned I uninstalled its own installed version of Privdog prior to trying the installer.

I also have previously used your tip to use a registry key to disable something else you introduced recently to Dragon … Comodo Message Centre ( Introduced here ) … it was an advertising mechanism for comodo products which I did not want installed but came by default with Comodo as enabled. The only method to turn it off being the registry key.

So for me personally its a bit of a bad doggy recently

The new version works wonder, except on Internet Explorer. Same unresponsive issue, page take ages to load, and still not compatible with Enhanced Protected Mode (WoT, AdblockPlus, DoNotTrackMePlus etc. all compatible with and without EPM, so no reason why PrivDog can’t).
But it is understandable, since this version is more like a minor fixes. It will likely require a major release to make PrivDog usable on Internet Explorer.

Thanks for your feedback, our IE team working on this issue.

Thank you for your feedback. It looks like a setup issue. We’ll investigate it.

Something else which may be worth looking into :

Because I do not use IE, I typically lock it down as much as possible in case anything jumps onboard and tries to take advantage of a less secure browser to execute its mischief …

So settings in Internet Explorer Options and manage addons etc - such as

Do not allow Third Party plugins

I would just want PrivDogSetup to install / update for Dragon and nothing else as a preference

But possibly it is choking on a user not allowing IE to have addons ?, may be worth looking into as something a user might set unusually.

why not create a debugger version for us so we can help you guys work out the kinks?